Receiving "performance counters" error when launching software

Hi - We are running a terminal services/Citrix server 2016 with about 25 users, and use the CRM software ACT version 20 (latest). When we launch ACT, after about 10 seconds, we get the error "The requested performance counter is not a custom counter, it has to be initialized as read only"  (pcerror.png - attached) . Of course, this being a terminal services/Citrix environment, happens for all users logging in and using the software. I've contacted ACT support, and they are claiming its a Windows problem. ACT Support did send me an article that has instructions on how to replace/reset the performance counters on the server, but it hasn't fixed the issue. Also, when the error occurs, there are about 6 or 7 miscellaneous events that show in the event viewer, which I've attached as well. I'm just not sure where this error is coming from, and any help with this would be greatly appreciated.
pcerror.png
perf1.png
perf2.png
perf3.png
perf4.png
perf5.png
perf6.png
hodgemAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ITguy565Commented:
Try running the application as Admin..
ITguy565Commented:
Has this ever worked in the past, or is this a fresh installation?

I am seeing a lot of architecture errors of 32bit programs running when a 64bit program is needed.
hodgemAuthor Commented:
Thanks for the quick response. Just tried running ACT as admin, received the same error..
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

ITguy565Commented:
Usually errors like this would indicate to me that a 32bit instead of a 64bit program was installed. It might also indicate an upgrade of a 32bit program over the top of a 64bit program that existed although most applications will not let you do that.
hodgemAuthor Commented:
Yes, this has worked in the past. ACT had an update (20.1) that I recently installed, which removes the previous version, and installs the updated version, and I still received the same error. Seems like problem is still hanging around even when the previous version is uninstalled. And, like I mentioned, I ran a script that apparently resets all of the performance counters, and THAT didnt work...
ITguy565Commented:
The 20.1 update was it 32bit or 64 bit?  The original application appears to have been 64bit.
hodgemAuthor Commented:
The one thing I also can tell you is, a couple months ago we upgraded from Server 2008 datacenter, to Server 2016 datacenter. I believe we didnt have this issue right after the upgrade, but maybe a couple weeks later, which makes me think the upgrade might not have anything to do with it.
hodgemAuthor Commented:
Apparently ACT only has a 32 bit version
ITguy565Commented:
That would explain why it is trying to call a 32 bit counter using a 64bit tool. However, I am not sure on the resolution

You say that
I've contacted ACT support, and they are claiming its a Windows problem.

I am not entirely sure of that.. As stated above. It is possible that it isn't compatible with that version of the OS, but that is not extremely likely. It is more likely that a configuration needs to be changed to allow for the use of the 32bit EXE for the performance counter.
hodgemAuthor Commented:
Not sure what you mean by "That would explain why it is trying to call a 32 bit counter using a 64bit tool"
ITguy565Commented:
I would probably call ACT back and see if I couldn't get to a level 2 tech or possibly even a supervisor and see if they can get this worked out for you. Else the only other option I could present would be to backup the ACT database. Uninstall ACT and Reinstall the application cleanly.. This still does not guarantee that it would work in the end.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hodgemAuthor Commented:
you mean because the OS is 64 bit?
ITguy565Commented:
The ACT application is a 32bit application.. Windows Server 2016 DC edition is 64 bit.. One of the errors you presented indiciate exactly that..

2018-04-03_10-25-16.png
ITguy565Commented:
Alternately, you could try installing the 64bit version of ASP.NET and see if that has an effect.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ACT

From novice to tech pro — start learning today.