How to removed sharing permissions for a user's Outlook Task List.

I have a user that wanted to share her 'Outlook Tasks' list with other users.  Now the same user does not wish for other users to view her Outlook Tasks lists.  While the user was logged on, I went the outlook client and removed the different users from having permissions to her Outlook task list.

it seems that everyone can still open her task list for some reason.  I ran the following command, from the Exchange PowerShell, to check on the server:

[PS] C:\Windows\system32>Get-MailboxFolderPermission -Identity USER1:\tasks


RunspaceId   : ca6ea022-9854-45d5-9445-714009be41ec
FolderName   : Tasks
User         : Default
AccessRights : {Owner}
Identity     : Default
IsValid      : True

RunspaceId   : ca6ea022-9854-45d5-9445-714009be41ec
FolderName   : Tasks
User         : Anonymous
AccessRights : {None}
Identity     : Anonymous
IsValid      : True

Question, What do I need to do to prevent others from being able to see this user's Outlook Tasks?

Will I need to remove the 'Anonymous' entry?
LVL 1
PkafkasNetwork EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AlanConsultantCommented:
Anonymous has no access rights - that is not the issue.

If you have one of the users that can still access the tasks list log out then back in to their computer (do a restart while at it), does that stop them accessing the task list?

Alan.
0
PkafkasNetwork EngineerAuthor Commented:
no, that does not change anything. Our users login through Microsoft terminal servers. I have indeed powered off and powered on those terminal servers over the past weekend.
0
AlanConsultantCommented:
Hi,

Please can you check the following:

1) From Outlook, the user right-clicks on 'tasks' and selects properties - Permissions.  Does this show anything different than the PowerShell report you posted?

2) If you log in to the Exchange Management Console, Recipient configuration, Mailbox - Select the user's mailbox, Right-click, Manage Full Access Permissions.  Is anyone (or a group) listed there that should not be?  If so, make a note of who or the group name, and remove them, then see if that fixes it.  If it doesn't, then consider replacing the object unless you are sure it should not be there.


Thanks,

Alan.
0
How the Cloud Can Help You as an MSSP

Today, every Managed Security Service Provider (MSSP) needs a platform to deliver effective and efficient security-as-a-service to their customers. Scale, elasticity and profitability are a few of the many features that a Cloud platform offers. Register today to learn more!

PkafkasNetwork EngineerAuthor Commented:
Everything looks to be in order for the user on the Exchange server end and the outlook end.

Server_perm
Equally important the Outlook Settings look to be identical to the Exchange permissions.

outlook_prperties_tasks
I am not sure what changes to make to prevent others from viewing this user's outlook tasks.  Perhaps this is one of those weird situations that requires a weird solution.
0
Mohammad Ishtyaq khatriSr. Systems EngineerCommented:
Ideally the Default permission should be set to none. I don't know what version of exchange you have.

But, I would recommend creating a new test mailbox and check its task permissions. Restore the same permissions on the users tasks and it should resolve the problem.

I have noticed that Default and Anonymous is set to none when no changes have been made.

Give it a try, but be sure to screenshot the existing permissions for that user before you make the change :)
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PkafkasNetwork EngineerAuthor Commented:
Yes, changing the default to 'NONE, instead of 'Full Details' worked.
0
Mohammad Ishtyaq khatriSr. Systems EngineerCommented:
Great to know!

It would be great if you can mark the solution as accepted :) Thanks!
0
AlanConsultantCommented:
Well spotted Mohammad - Right there is front of us!

Alan.
1
Mohammad Ishtyaq khatriSr. Systems EngineerCommented:
Thanks Alan!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Powershell

From novice to tech pro — start learning today.