Remote Desktop Not Working

I have a Windows 2008 server with SP2 that used to run Remote Desktop just
fine. We rebooted one of them yesterday and after the reboot, Remote Desktop doesn't work anymore.

1. The server does not have any firewalls (windows or third party) running
2. netstat -an, port 3389 doesn't show up.
3. When I check the services, terminal services is running,
4. I deleted and tried recreating the rdp connection under "Terminal Services Configuration" but it did not help.
5. I had checked the registry and port 3389 is configured to be listen
6. I had changed the registry and port 3390 is configured to be listen
7. I am sure Remote Desktop is checked in the Remote property
8. "RDP-Tcp (listener)" does not show up under the "Terminal Services Manager"
9. I have restarted the server many times.
10. Event logs does not shows any errors about the RDP service

Any suggestion?
Anand GuruAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zvitamConsultantCommented:
What error message you get when you try to connect?

Have you try connecting from different client or you get the error on a certain client?
0
Anand GuruAuthor Commented:
Error: This computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator.

But The Remote is Enabled.

We can able to PING, Shared folder Access and VPN also.

Same Network only
0
MaheshArchitectCommented:
have you tried telnetting server from client on tcp 3389? is it working?
if you change rdp port in registry, r u able to telnet it?
u need to tell client to use custom port while taking rdp?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

PerarduaadastraCommented:
I answered a similar question recently here:

https://www.experts-exchange.com/questions/29091083/windows-10-PRO-edition-is-not-listening-on-port-3389-for-RDP-connections.html?notificationFollowed=205863683#a42513945

It's easy to make the mistake described, and equally easy to either fix it or to eliminate such an error as the cause of your issue.
0
Anand GuruAuthor Commented:
i have checked. the registry value is 3389 only there
0
Anand GuruAuthor Commented:
I am not having telnet server so we cant able to check the status

But PortQryV2 Command using my result shows TCP port 3389 (ms-wbt-server service): NOT LISTENING
0
MaheshArchitectCommented:
you just need to install telnet client on machine from where you are testing RDP and check if telnet is working?

U don't need to install telnet server on server in issue
0
Anand GuruAuthor Commented:
If I am Run the telnet client on my machine

Error  Could not open connection to the host, on port 3389: Connect failed
0
backhaulCommented:
Good Day,

would you please provide a "netstat -an" from the command line?

Thanks!
0
Anand GuruAuthor Commented:
i have checked netstat -an, port 3389 not showing
0
MaheshArchitectCommented:
now install telnet client on sever in question and run there telnet localhost 3389 and see if its working
if worked, it means some where rdp port is blocked in between, in firewall or something?
if did not worked, it means server failing to run RDP protocol, may be you can check if fdenyterminaslserver registry set to 1
0
backhaulCommented:
Hello,
sorry you had mentioned a few of the items in your first list you posted.  It states you changed the port to 3390 or am i misreading the post.
Is this a stand alone device or is it part of a domain?
Thanks
0
PerarduaadastraCommented:
Open Task Manager and click on the Processes tab. Then click on View in the menu bar, click on Select Columns, put a tick in the PID box, and click OK. Now click on the Services tab and locate the TermService service and make a note of its PID. Minimise Task Manager, open a command prompt, and run this command:

netstat -a -n -o

The output will list, among other things, the PIDs of the services using the listed ports. As the TermService service runs under a svchost.exe process there will be several entries having the PID you've noted; the computer I'm using to type this has five occurrences of the PID used by the TermService service, three of which I can ignore because those services are using port numbers above 49000, and the other two are using the expected RDP port number.
In your case I would look for services with the noted PID using port numbers below 20000  (at least initially) and having either the local IP of the server or the loopback address in the netstat output line, and try connecting to the server with RDP using those ports.
0
Rob WilliamsCommented:
Sounds overly simple, but at least 20 times over the past 15 years after a reboot, especially if updates were applied, remote desktop failed.  A second reboot instantly fixed the problem with with no other changes.  For this reason all the servers I manage have an alternate way to access, I use GoToAssist, but LogMeIn, ConnectWise, or many others work well.  They allow you remote access to resolve the problem.
0
Anand GuruAuthor Commented:
This Server is primary domain server.

And one more thing, we have facing this same  issue 2 days before but we resolved that issue.

We can go to regedit and local root give permission to the administrator. after thet working normally

After reboot we facing the same issue now permission also there in administrator.
0
Anand GuruAuthor Commented:
fdenyterminaslserver is not available in regedit only available on fDenyTSConnections
0
Anand GuruAuthor Commented:
If i am saw the Event log in our server, I have an error

Terminal Service start failed. The relevant status code was Could not read key from registry

Event ID 1048
0
PerarduaadastraCommented:
Well, perhaps that clarifies things a bit. If the Terminal service is unable to start because it can't obtain the necessary information from the registry, that would explain its failure to be listening on any port; furthermore it wouldn't appear in the list of running services.

The failure to access the relevant registry key(s) suggests registry corruption or possibly a permissions issue on the keys, so that's where to start looking.
0
Anand GuruAuthor Commented:
Then What is the Solution? How it will be resolve?

Kindly advice us.
0
Jignesh JainSr. Oracle Apps DBACommented:
It seems that the Terminal Server is Expired. First login as Administrator. Open Registry. Open the following folder

HKEY_LOCAL_MACHHINE\CurrentContolSet\TerminalServer

Delete GarcePeriod folder. And Restart Machine.
0
PerarduaadastraCommented:
If I remember correctly, the GracePeriod folder exists only in RDS installations where access depends on the number of current licenses available for such access. For bog standard Server 2008 installations the limit is two, and if a third connection is attempted an error message appears informing the user that the number of allowed connections has been exceeded.
The OP hasn't said anything to suggest anything other than a standard Windows Server 2008 installation. Even if it was an RDS machine the service would still have to be running in order to generate a licensing error, and the problem is that the service fails to start because it can't obtain data from a part of the registry needed for the service to run.
0
Anand GuruAuthor Commented:
Hi Friends,

Thanks for your Information, But GracePeriod folder is not there in registry

i have used Windowserv server 2008 Sp2

Kindly give any other solution?

High Priority
0
PerarduaadastraCommented:
Well, there seems little doubt that it's a permissions issue on the keys needed to be read for the Terminal Service service to start, as the error in Event Manager says as much, and you've already had a registry permissions issue and resolved it successfully.

I'm wondering if the server loaded a different control set during that fateful reboot which for some reason doesn't have the correct permissions assigned. Have you tried modifying the relevant permissions in the ControlSet001 and ControlSet002 as well as in CurrentControlSet?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Anand GuruAuthor Commented:
Hi Friend,

Thanks for your response

Now i can able to take remote. After delete the permission and again given to HKLM, HKCR, HKCU and all

Full Permission given to the system and Administrator Users

After that working normally.
0
PerarduaadastraCommented:
Excellent. I do so like happy endings!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.