• Status: Solved
  • Priority: Low
  • Security: Public
  • Views: 60
  • Last Modified:

Error accessing web site with https

Hello,

I am trying to connect to the management console of a device on my local network (https://xxx.xxx.xxx.xxx), and I get the following error (in Chrome):

NET::ERR_CERT_AUTHORITY_INVALID

I then click advanced and select continue, but I get another error :

The connection was reset.  ERR_CONNECTION_RESET

I have cleared the cached, run ccleaner, disabled tls 3.

I also tried the same thing in Firefox with the following error:

Secure Connection Failed
The connection to the server was reset while the page was loading.

Any suggestions on how to fix? I was connecting to in via HTTP and I changed it to https access.

Thanks in advance.
0
Mark Budman
Asked:
Mark Budman
1 Solution
 
Kyle AbrahamsSenior .Net DeveloperCommented:
You can look at the security details to see what the certificate name is.  
From there you can edit your hosts files so the IP address is used for the name on the certificate.  That should get you further when going to https.  Essentially though for the certificate to be valid it needs to match the name of the domain.

EG: If I have a cert for XYZ.com it will only apply to XYZ.  If I type in the IP (even though it's the same machine) or type in ABC.com (which may be a sister site or duplicate domain) the certificate won't work.
1
 
masnrockCommented:
Sounds like it's using a self-signed certificate, which does tend to be the cause of the first message.

Also, try restarting Chrome and your computer (assuming that you haven't already). There are times where Chrome just starts doing dumb things, and a simple restart clears issues out.
1
 
nociSoftware EngineerCommented:
there are 2 clases of certificates:
1) Self signed the have no other party signing the certificate.
2) A certificate is signed by a parent certificate which is signed by a parent ... until you have the root certificate.

That root certificate should be a Trusted certificate (from a Certificate Authority (CA)) to be acceptable.
So Either you have a selfsigned certificate (No Root CA)
Or you have one of which t eroot CA is unknown to you system.
(Can happen because the CA has been revoked from the trust database (happened to Diginotar, and more recently Wosign & StartSSL).
or because the Root CA is a private (Company Root CA for internal use).
1
 
StolsieCommented:
Hi
in addition to what been said above,
there should be the options to ignore the warnings and/or add exceptions to the certificate error.
if its only for you once you have got on the device there should be a certificates tab for you to download it, you can manually add it to your PCs root certificates
0
 
Mark BudmanAuthor Commented:
Thank you for your assistance
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now