Unable to install Server 2016 updates

For the last 3 months on a Server 2016 Hyper-V base server and two Hyper-V virtual servers, I have been getting the error message shown in the screenshot "There were some problems installing updates, but we'll try again later. If you keep seeing this and want to search the web or contact support for information,  this may help (0x8000ffff) (see the screenshot).

These servers are running Server 2016 Datacenter and have all been properly activated with a valid serial number. There is currently no Windows Server Updates Server being used within this network.

Sometimes I will actually get a list of which updates need to be installed and will then click on the "Install Now" button (see the second screenshot). The updates will appear to be installing but they will never actually finish and I will continue to get the original error message mentioned above. Also if I restart or shut down Windows the updates never go through the next stages of the install process and when Server 2016 finishes loading I check and the updates haven't installed and the original issue continues to occur when I check for updates and attempt to install them.

I have clicked on Retry, have rebooted the server and have run several other repairs including:

1. Clearing temporary & temporary internet files including the Recycle Bin
2. Running the SFC, DISM, and chkdsk commands
3. Running several Symantec Antivirus and Malwarebytes antivirus scans which have found no problems

However, the server has been unable to install any Windows updates using the Windows Update applet and I have had to manually install the Windows updates on all three servers.

What can I do to fix this issue so that I will once again be able to install Windows updates on these servers?

Svr-2016-Win-Updates-Error messageSvr-2016-Updates-To-Install
IT GuyNetwork EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
8000ffff is often a networking issue. My first guess is that something clobbered the hyper-v networking stack, virtual switch, etc. Antivirus software not built for hyper-v cam easily do this. As can just misconfiguration.
IT GuyNetwork EngineerAuthor Commented:
What steps can I follow to further troubleshoot and fix this issue?
Since these updates have been already downloaded, I doubt that it is a network problem.

I would do an in-place upgrade using the server 2016 setup. That repairs all internals, but keeps programs, data and setting. This is often used successfully to overcome all sorts of errors with updating.
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

IT GuyNetwork EngineerAuthor Commented:

Can you please provide me with the steps on how to do an in-place upgrade?
Insert the usb setup stick or setup dvd and start server 2016 Setup within the running system. Same process as for win10, see https://www.tenforums.com/tutorials/16397-repair-install-windows-10-place-upgrade.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David Johnson, CD, MVPOwnerCommented:
what I had to do was 2 stages

1) Run the windows update troubleshooter as an admin.. I always get an error on the catalog being corrupted and not able to be fixed so I ignore it
Try updates again if still failing I run the following as a batch file (as administrator)
net stop wuauserv
net stop cryptsvc
net stop bits
net stop msiserver
rd c:\windows\softwaredistribution.old /s /q
rd c:\windows\system32\catroot2.old /s /q
ren c:\windows\softwaredistribution softwaredistribution.old
ren c:\windows\system32\catroot2 catroot2.old
Net start wuauserv  
net start cryptsvc
net start bits
net start msiserver

Open in new window

Davis McCarnOwnerCommented:
Since these are virtual machines, the starting point is really the host.  Has it successfully installed all of its updates?
IT GuyNetwork EngineerAuthor Commented:
No the host machine and the virtual machines are all having the exact same problem where they are unable to install the Windows updates.
Davis McCarnOwnerCommented:
Stop the virtual machines and then try updating the host.
IT GuyNetwork EngineerAuthor Commented:
Can you provide me with the instructions for running the Windows update troubleshooter?
Davis McCarnOwnerCommented:
They are all over the web and I've had about a 50% success rate using them; but, I still think you NEED to close the VMs before trying to install the updates on the host PC.
IT GuyNetwork EngineerAuthor Commented:
I have already shut down the two Hyper-V virtual machines and then rebooted the base server and tried installing the latest Windows updates on the base server but I continue to have the same results.

I have already googled the Windows update troubleshooter and see that there are different versions.

I haven't been able to find a Windows update troubleshooter that specifically says that it is for Server 2016 but have found ones that say that they are for Windows 10.

Should I use the Windows 10 update troubleshooter for Server 2016 or is there a different one, preferably one that is designed specifically for Server 2016? If so what is the URL address for that troubleshooter that is designed for Server 2016?
Honestly, I have never seen "windows update trouble shooter" change anything.
Try David's script, if that does not work, do an in-place upgrade as described before.
IT GuyNetwork EngineerAuthor Commented:
The In-Place upgrade is the only solution to the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Updates

From novice to tech pro — start learning today.