google earth will not start in direct x mode

windows10 laptop

google earth latest edition

only open gl works

I uninstall
safe mode,
restore default settings
delete my places
turn off atmosphere

even though I uninstall/re install

direct x will not work.
start google earth many times
LVL 1
rgb192Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

☠ MASQ ☠Commented:
If you run DXDiag and choose "Save all information" can you post the log file here?

Best guess without is you have a default graphics driver installed which isn't fully DX compliant and you need the manufacturer's version or if your system isn't fully DX10 or 11 compliant need to install an older DX runtime library.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Leonidas DosasCommented:
What graphics card has the laptop?
0
rgb192Author Commented:
0
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

☠ MASQ ☠Commented:
OK. You have dual graphics options the integrated HD630 and for more demanding graphics the nVidia GTX1050T

We need to get your machine to switch to the nVidia graphics for Google Earth

1. Right Click on your desktop
2. Select the nVidia Control Panel
3. In the left-hand panel select "Manage 3D Settings"
4. In the right-hand panel select the 'Global' Tab
5. Under "Preferred Graphics Processor" select "Auto-Select" and hit 'Apply'

Now try Google Earth again and see if it properly selects correct GPU.

If not then instead of 'Global' in the right-hand panel select the 'Program Settings' tab
Check the box for "Only programs on this computer" then use the "Add" button and find Google Earth in the list under Section 1.  Now go down to section 2 and select your nVidia processor.
0
rgb192Author Commented:
Under "Preferred Graphics Processor" select "Auto-Select" and hit 'Apply'
already there


no change made.

So what change should I make?
0
☠ MASQ ☠Commented:
Check the box for "Only programs on this computer" then use the "Add" button and find Google Earth in the list under Section 1.  Now go down to section 2 and select your nVidia processor.
0
rgb192Author Commented:
I made the section 2 select nVidia processor
but google earth still crashes at startup if I am using direct x
0
rgb192Author Commented:
diaxdiag
provides alot of useful information to troubleshoot

the way to solve a problem is to give alot of data

thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Google

From novice to tech pro — start learning today.