babel node error

Hi Experts,

I get the following error when I run babel-node

Please see the error below


root@ip-10-252-14-11:/home/ubuntu/workarea/sourcecode/ntdl# babel-node node/react-render.jsx

/usr/local/lib/node_modules/@babel/core/node_modules/@babel/template/lib/builder.js:86
      throw err;
      ^

Error: Unknown substitution "BODY" given
    at /usr/local/lib/node_modules/@babel/core/node_modules/@babel/template/lib/populate.js:22:15
    at Array.forEach (<anonymous>)
    at populatePlaceholders (/usr/local/lib/node_modules/@babel/core/node_modules/@babel/template/lib/populate.js:20:31)
    at /usr/local/lib/node_modules/@babel/core/node_modules/@babel/template/lib/string.js:20:51
    at /usr/local/lib/node_modules/@babel/core/node_modules/@babel/template/lib/builder.js:83:14
    at spec (/home/ubuntu/workarea/sourcecode/ntdl/node_modules/babel-plugin-transform-es2015-for-of/lib/index.js:159:20)
    at PluginPass.ForOfStatement (/home/ubuntu/workarea/sourcecode/ntdl/node_modules/babel-plugin-transform-es2015-for-of/lib/index.js:72:21)
    at newFn (/usr/local/lib/node_modules/@babel/core/node_modules/@babel/traverse/lib/visitors.js:223:21)
    at NodePath._call (/usr/local/lib/node_modules/@babel/core/node_modules/@babel/traverse/lib/path/context.js:64:19)
    at NodePath.call (/usr/local/lib/node_modules/@babel/core/node_modules/@babel/traverse/lib/path/context.js:38:17)
    =============
    at exports.default (/home/ubuntu/workarea/sourcecode/ntdl/node_modules/babel-plugin-transform-es2015-for-of/lib/index.js:11:20)
    at /usr/local/lib/node_modules/@babel/core/lib/config/index.js:167:14
    at cachedFunction (/usr/local/lib/node_modules/@babel/core/lib/config/caching.js:40:17)
    at loadPluginDescriptor (/usr/local/lib/node_modules/@babel/core/lib/config/index.js:202:28)
    at /usr/local/lib/node_modules/@babel/core/lib/config/index.js:59:16
    at Array.map (<anonymous>)
    at recurseDescriptors (/usr/local/lib/node_modules/@babel/core/lib/config/index.js:58:36)
    at recurseDescriptors (/usr/local/lib/node_modules/@babel/core/lib/config/index.js:92:27)

my  babel-node version is

root@ip-10-252-14-11:/home/ubuntu/workarea/sourcecode/ntdl# babel-node --version
7.0.0-beta.40


my package.json file contents is

{
  "name": "ntdl",
  "version": "1.0.2",
  "description": "Build and rendering server for NTDL django project",
  "license": "SEE LICENSE IN license.txt",
   "devDependencies": {
    "@babel/cli": "^7.0.0-beta.3",
    "@babel/core": "^7.0.0-beta.3",
    "@babel/node": "^7.0.0-beta.3",
    "@babel/register": "^7.0.0-beta.3",
    "babel-cli": "^7.0.0-beta.3",
    "babel-core": "^7.0.0-beta.3",
    "babel-eslint": "^6.1.2",
    "babel-loader": "^7.0.0-beta.1",
    "babel-plugin-transform-decorators-legacy": "^1.3.4",
    "babel-plugin-transform-object-rest-spread": "^7.0.0-beta.3",
    "babel-plugin-transform-optional-chaining": "^7.0.0-beta.3",
    "babel-preset-env": "^2.0.0-beta.2",
    "babel-preset-react": "^7.0.0-beta.3",
    "babel-preset-stage-3": "^7.0.0-beta.3",
    "babel-register": "^7.0.0-beta.3",
    "cssmin": "^0.4.3",
    "eslint": "^3.11.1",
    "eslint-plugin-react": "^6.8.0",
    "uglify": "^0.1.5"
  },
  "scripts": {
    "start": "concurrently --no-color \"npm run pack\" \"npm run django\" \"npm run render\"",
    "partial-start": "concurrently --no-color \"npm run pack\" \"npm run render\"",
    "start-prod": "concurrently --no-color \"uwsgi --ini /home/ntdl/code/uwsgi.ini\" \"nginx\" \"npm run render-prod\"",
    "pack": "webpack --watch --config node/webpack/webpack.config.js",
    "pack-prod": "webpack --config node/webpack/webpack.production.config.js",
    "django": "python manage.py runserver",
    "render": "babel-node node/react-render.jsx --watch",
    "render-prod": "babel-node node/react-render.jsx",
    "pylint": "pylint ntdl cms search",
    "eslint": "eslint static/style/style.js && eslint --ext .jsx search",
    "lint": "npm run pylint && npm run eslint",
    "es-index": "babel-node elasticsearch/index/create.js",
    "migratedb": "python manage.py migrate"
  },
   "dependencies": {
    "autobind-decorator": "^2.1.0",
    "babel-eslint": "^6.1.2",
    "babel-polyfill": "^6.23.0",
    "body-parser": "^1.17.2",
    "coffeescript": "^2.2.4",
    "concurrently": "^3.5.0",
    "elasticsearch": "^12.1.3",
    "express": "^4.15.4",
    "graceful-fs": "^4.1.11",
    "history": "^4.7.2",
    "material-ui": "^0.16.7",
    "minimatch": "^3.0.4",
    "node-sass": "^3.13.0",
    "openseadragon": "^2.3.0",
    "pdfjs-dist": "^1.8.492",
    "query-string": "^5.0.0",
    "react": "^15.6.1",
    "react-dom": "^15.6.1",
    "react-redux": "^5.0.6",
    "react-render": "^1.2.1",
    "react-router": "^4.2.0",
    "react-router-dom": "^4.2.2",
    "react-router-redux": "^5.0.0-alpha.6",
    "react-tap-event-plugin": "^2.0.1",
    "redux": "^3.7.2",
    "redux-thunk": "^2.2.0",
    "request": "2.79.0",
    "webpack": "^3.5.5",
    "webpack-bundle-tracker": "0.1.0",
    "yargs": "^6.6.0"
  }
}

my .babelrc file contents are

{
  "presets": [
    "react",
    ["env", {
      "targets": {
        "browsers": ["last 2 versions", "ie >= 11"],
        "node": "current"
      }
    }]
  ],

  "plugins": [
    "transform-decorators-legacy",
    "transform-optional-chaining",/
    "transform-object-rest-spread"
  ]
}

Please tell me how to resolve this error.  and guide me the best practices for using babel

What is the difference between babel-core vs @babel/core?   Please through some light over it.

I had tried removing node-modules folder and got the old babelrc, package.json, same old source code from git and tried npm install and npm run render.  I get the same issue
still I get the same issue.  I had make changes to dev dependencies in package.json all point to same version 7.0.0-beta.3, still throwing the same error.

With Many Thanks,

Bharath AK
LVL 1
Bharath A.KAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bharath A.KAuthor Commented:
Hi All,

I am able to resolve this issue.  I had install all same versions of babel.  i.e babel-core, babel-loader, babel-register, babel-node,babel-cli etc all plugins same version babel@7.0.0-alpha.20.  The important thing I had removed '^' from all babel's i.e I had removed babel-core@^7.0.0-alpha.20  removed ^ in all babel's on package.json.  Installed exact same version no caret's.  Babel node is tool which is run the script file.  I had changed the babel-node to same version.  All in the same version resolved the problem.

With Many Thanks,

Bharath AK

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Node.js

From novice to tech pro — start learning today.