Calibri Bold Printing Issue

Calibri Bold Print Issue;

When printing certain documents with Calibri Bold, the job either errors in queue or the printer errors and cancels the job.  This can be reproduced using Wordpad on different environments, server 2012R2, Windows 10, Windows 7, Office 2013, Office 2016.  Printer makes, Olivetti, Ineo, Ricoh, Konica Minolta and HP.  If you change the first letter of the document from bold to standard Calibri it prints without issue.  Firmware has been updated in one case, however the issue remained.

We have also tried replacing the font with an older versions , however this makes no difference and the job still errors or doesn't print.  The only work around is to change the driver to PCL5, PS or adjust the PCL 6 driver to render the font as Bitmap, or Raster instead of vector and the problem documents print fine.

We know there have been issues with the Calibri font in the past, however there must have been something possibly an update to the printer engine that has caused this issue to start occurring.  Any help gratefully received.
BluecubeTechnologyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sigurdur ArmannssonDesigner Commented:
Do you see anywhere an option to let the printer only use downloaded fonts? The issue could be that the printer is trying to use its installed fonts and trying its best to match Calibri.

I read somewhere of a similar problem that was solved if the first letter of each page was not Calibri Bold. But that is of course difficult to ask anyone to adjust too. It would be tempting to try out what happens if you could Calibri Regular a white dot (punction mark) as small as possible, as the first letter on a page.

Please take a look at these solutions:
https://answers.microsoft.com/en-us/msoffice/forum/msoffice_word-mso_other-msoversion_other/office-2010-word-calibri-font-printing-issues/8fbd59b0-5682-43cc-8476-e7dbed314f1e

https://support.microsoft.com/is-is/help/960985/the-characters-in-an-equation-are-not-printed-when-you-print-a-word-20
DansDadUKCommented:
Until recently, few printers included Calibri as one of the printer-resident fonts (e.g. LaserJet Pro 400 MFP M475dn does not include it, but LaserJet  M553 does).

If a source document uses a (display) font which is not one of those which the printer driver recognises as being printer-resident, then (depending upon the source application and printer driver and driver settings) one of the following methods is used to print the data:

The text is rasterised on the workstation, and an encapsulated raster image of the text is sent to the device.
The driver substitutes a known printer-resident font for the unavailable one; this is based on what (the driver thinks is) a 'closest match', but the two fonts may turn out to be substantially different, of course.
The driver dynamically generates and downloads an (encapsulated, printer-format TrueType) equivalent of the source TrueType / OpenType font.
The driver dynamically generates and downloads an (encapsulated, printer-format bitmap) equivalent of the source TrueType / OpenType font.

It would seem (from your comments) that the PCL6 (PCL XL) driver uses the third or fourth of these methods (depending on the
'render as bitmap' option setting.

The problem occurs without the 'render as bitmap' option, so it seems that the issue is with use of a dynamically generated printer-format TrueType font; without much more detailed evidence it is very difficult to ascertain where the problem lies; for example:

There is some minor fault with the source font which the 'translation' process does not handle correctly.
There is a fault within the translation process itself.
There is a fault within the printer firmware which cannot handle the dynamically generated font.
... something else.
BluecubeTechnologyAuthor Commented:
Hi @DansDadUK

That would make sense, certainly one of the cases the customer had a HP LaserJet 400.  We had replaced the Calibri font including the bold version, to 6.20, 6.18, 5.89, 5.84 and 5.74, however the job still errors at the printer.

Certainly given the issue with one example HP P3015, it would start up, as if to print the job and then nothing.  This device has now had a firmware update, which included font table.  In another example, the printer is a brand new Konica Minolta, with the latest firmware, but this still errors at the printer.

Many thanks for you input!
DansDadUKCommented:
I missed your original comment about “changing the first character of the document...”.
Perhaps this indicates a problem with the source application (Word?).


As regards the “printer errors”, can you post exact details of those errors?
BluecubeTechnologyAuthor Commented:
Unfortunately, the same happens in Wordpad, MS have said it's a system issue and not an office one. I'll post an error from one example Ricoh printer.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.