After rebooting windows server 2012, it got stuck at "Windows Logo" icon. No progress.

After rebooting windows server 2012, it is not coming up. I only see Windows logo, no progress , nothing. I waited for 4 hours but still nothing is happening. It shows Windows logo.
This is VM machine hosted on VMWare 6.0.  I tried following
1. Rebooting in Safe mode
2.  http://www.hackaapl.com/repairing-windows-2012-r2-startup/
3. Followed some VMWare article
4. Last known good configuration

Nothing helped.
LVL 1
Arif KhanSystem AdministratorAsked:
Who is Participating?
 
Arif KhanConnect With a Mentor System AdministratorAuthor Commented:
The Solution:

Reboot the server, press F8 to access advanced boot options
Select the Option "Repair Your Computer"
In the Options screen select Troubleshoot > Command Prompt
The server boots into a limited command prompt at the X drive.
Get a list of all the available drives, type “wmic logicaldisk get name“. This is important as whilst in the repair environment the drive mappings often get changed around i.e. I was panicking when I changed to the C drive only to find it was empty. In fact the system drive was mapped to the E drive. There’s no obvious way to tell, you just have to change to each drive mapping a run a Dir command. (To know for sure, you can cd to every drive listed above and check if that has Windows related directory. )
Navigate to the \Windows\Winsxs folder. Once here you need to find all the files called pending.xml* and rename them all by adding .OLD to the end of the file name. (In my server I had two pending.xml and pending.xml.random_number – I added .OLD to the end of both of these). The reason for this is it’s in one of these there is a corruption that’s the cause of the problem. ren pending.xml pending.xml.old
If you have a lot of files with the name and a sequence of numbers, you can use the following from the commandline: for /r %i in (pending.xml*) do move %i %i.old
Create a new blank pending.xml file in the \Windows\Winsxs folder; echo > pending.xml
Next up is to run a DISM command to remove/revert all pending actions from the image, in our case these updates attempting to install. However before doing so you must create a scratch folder for the temporary files to be stored in. If you don’t complete this step you will get a 3017 error, which complains the default temporary location for the scratch folder is too small. Create the scratch folder in the \Windows directory; mkdir \windows\scratch
Run the following command (NB my system drive was mapped to the E drive); DISM /Image:E:\ /Cleanup-Image /RevertPendingActions /scratchdir:E:\Windows\Scratch
Once complete rename the \windows\SoftwareDistribution to SoftwareDistributionOLD; ren E:\windows\SoftwareDistribution SoftwareDistributionOLD
Finally, run sfc /scannow – the System File Checker tool to repair missing or corrupted system files
Reboot the server. The start-up splash screen should show spinning dots for a minute or two then boot normally. In my instance it then reported updates couldn’t be installed and so reverted those that had been installed. It then forced another reboot.
At this stage the server is ready to have updates installed, but this time only do a few at a time to locate the faulty update.
2
 
Hypercat (Deb)Commented:
First, try shutting down the Windows 2012 VM completely, rather than just rebooting, if you haven't already tried that.

If that doesn't work, try the steps in this article:

https://kb.vmware.com/s/article/2092807?src=vmw_so_vex_mbrad_895

It says the article applies to ESXi 5.5 but I've also seen the behavior with 6.0.
0
 
Arif KhanSystem AdministratorAuthor Commented:
I tried but it did not help me.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Arif KhanSystem AdministratorAuthor Commented:
Above fixed my issue.
0
 
Hypercat (Deb)Commented:
Please mark your post with the steps that fixed the problem as the accepted answer. Also if you got this answer from another post, either on EE or on another forum, please include a link to the original post.  

This will help others with the same problem who may be searching EE for helpful information, as well as giving credit to the source.

Cheers,

Deb
0
 
Arif KhanSystem AdministratorAuthor Commented:
Earlier I could Mark as Best answer and assisted answer but Now I don't see these option. I am unable to close this case. For reference below  URL


https://serverfault.com/questions/762270/windows-server-2012-r2-update-stuck-after-restart-at-9
1
 
Arif KhanSystem AdministratorAuthor Commented:
This fixed the problem
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.