Router blocking certain traffic but not all

I have a small business network running one server (SBS 2003) with about 7 workstations.  The server has been configured to forward a copy of all my mail (for my user only) to my home email address (a gmail account), this has worked fine for years.

Recently our TP-Link router began to misbehave (had to restart it every day to restore internet connection), so I replaced it with a new TP-Link Archer C-9.  I copied all the settings from the old router into a Word doc, and configured the new one with all (I think) the same settings.  (Tried exporting settings from old one & importing into new router but new one didn't like the exported file.)

Everything is working fine EXCEPT two things:

1) My mail is no longer forwarding to my home address.  I don't get any error messages or anything, just no mail at home. Emails that are MANUALLY sent out to my home address DO go through, just the automatic forwarding has stopped working.

2) We use a little instant messenger program called Big Ant, and now my home machine cannot connect to the Big Ant server - which is my workstation at the office.  All other machines inside the network can connect to it fine, just not my home machine which of course is outside the network (this was working fine before the router change).

Nothing on the server has changed, nothing on my workstation has changed - only change is the new router.

Appears to me that the new router is blocking these communications for some reason.

Any ideas are much appreciated!
cricketmanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

masnrockCommented:
Are your rules appropriately labelled so that you can recognize their purpose? BigAnt appears to require TCP port 6660 for IM, TCP port 6661 for document management (if you use it), and UDP port 6662 for audio/video.

On your router, review the rules on Virtual Servers (should be within Advanced), and make sure they are set correctly..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Nick FordInformation Systems TechnologistCommented:
I know you had said you don't receive any errors, but it would be a good idea to logon to the router and look at the logging. That should tell you right there exactly what the issues are. I'd be willing to bet there were rules and/or exceptions for both Big Ant and your mail forwarding that weren't [correctly] copied to the new router. Start with the logs.
0
masnrockCommented:
Nick beat me to the next point I was going to bring up. ALWAYS check the logs.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

cricketmanAuthor Commented:
I do remember the Big Ant port usage you noted, but I did not see any rules for that in the Virtual Servers on the old router.

There were a couple other rules there for remote desktop connections (one for me to login to the server, and one to login to my personal workstation)... the RD connection for the server is working fine, but one for my desktop is not (I didn't mention that in first post thinking that since the server one is working, I may have just made a typo in the one for my workstation).

I recreated all the existing rules (I think)... one of which I do remember referenced port 25, which is for SMTP, right? (I know SOME of this stuff, but I'm not a professional)... but since "normal" (manually dispatched) email is working fine, I'm stumped on why it's not forwarding.


I will check the logs, and the virtual server rules again - thanks guys.
0
masnrockCommented:
Correct that SMTP does use TCP port 25 by default. What you may more ideally want to have is some sort of external spam filter (if you don't already have one).

What model was the old router?
0
cricketmanAuthor Commented:
Old router was a TP-Link TL-WR1043ND.

I'm about to check the router logs & virtual server settings again now...
0
masnrockCommented:
Another place to check would be the DMZ, which is also under forwarding. (There can be more than one way to approach things, so the big thing is how you might've gone about it)
0
cricketmanAuthor Commented:
OK, PARTIAL success.

I added virtual servers with the appropriate ports to point to the Big Ant server (my workstation), and that solved the Big Ant issue.

But still no email forwarding.

The router's logs only had entries relating to the port settings I made, and a few that had TYPE=NAT, and the content was "[2989] Initialization succeeded."  Nothing that looked to me like it is related to mail, and nothing said "error", or "blocked", etc.

And the DMZ section of my old router's config is blank - nothing setup.

Any other ideas?

Would it help if I uploaded the old router's config file (a Word document) so you guys could peruse it?  And the new router's file also if needed?
0
cricketmanAuthor Commented:
And masnrock - I do have an external spam filtering service... could it be something they need to do on their end?  Since I can manually send/receive emails fine, I assumed nothing needed to be done on their end, but... am I missing something?
0
cricketmanAuthor Commented:
I re-checked the virtual server settings for my remote desktop connections again, they all look correct in the router.

The connection for my main file server works fine, but one for my workstation still did not, so I checked the RDP port setting in the registry of my workstation, it wasn't what I expected - it was still set to port 3389 (which is the default, right)... I have a practice of naming my workstations with a number (every time I buy a new machine it gets the next increasing number)... my current workstation is "W-28"... so if I want remote desktop for a machine, I change the RDP port setting in that machine so the last 2 digits match the workstation number, so in this machine I made the port setting "3328" (and rebooted the machine).  

Since the RDP connection for my file server is working fine, I thought for SURE this was going to fix the problem with RDP for my box, but - still no connection.  

I have the virtual server external port & internal port both set to 3328, and the IP address set to the IP of my machine (192.168.1.28).  My RD connection for the SERVER is aimed at "<my-static-public-ip>:3389" and it connects just fine, and for my workstation it's aimed at  "<my-static-public-ip>:3328", but it does not connect.  This always worked before with previous routers, but no joy now.

And still no email forwarding.

Any more ideas anyone???
0
cricketmanAuthor Commented:
Creating port rules for the BigAnt ports solved that issue.

The other issue of email not forwarding was solved by recreating the forwarding setting for my user on my SBS2003 server. Those settings had been there & working fine for years, but for some reason stopped working after installing the new router. Deleting the forwarding setting & recreating it solved the problem - email is properly forwarding now.

Thanks to all who offered advice!
0
cricketmanAuthor Commented:
Thinking this was actually a different question that was not solved by any answers posted, when closing this question I clicked to close it without awarding any points. Once I was further along in the process, I realized that part of this question WAS resolved by an answer posted by masnrock, so I should have awarded points to him (or her?).

If someone will tell me how to award points after the question has been closed I will gladly do so!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.