Getting the sound to work in a Hyper-V VM in a Windows 10 Pro computer

We have a Windows 10 Pro computer that uses Hyper-V VM but the sound is not working.  What can we do to get the sound working?
rayluvsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
The VM is running on Windows 10 Pro Hyper-V? In Hyper-V Manager right click on the Computer Name --> Hyper-V Settings --> Enhanced Session Mode Policy --> Tick to ALLOW.

When opening a VM Console Session allow the enhanced session and log on. Sound should be enabled. If the VM is a Server OS then right click on the Sound/Speaker and click on any option then click YES to the Enable Audio Services prompt.
1
Shaun VermaakTechnical Specialist IVCommented:
Or just RDP to this virtual
0
rayluvsAuthor Commented:
Just checked, Enhanced Session Mode Policy is allowed.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

rayluvsAuthor Commented:
When in VM, it always detect the sound when clicking on the speaker icon... but no success (see pix below).

vmsound
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Make sure Integration Services are up to date as that looks like a snip from Win7.
0
rayluvsAuthor Commented:
yes, forgot to mention, the Vm are Windows 7 Pro... i think Integration Services  is installed but will check...
0
R@f@r P@NC3RVirtualization SpecialistCommented:
Hello,

Validate if the device manager, you may need to install or update some sound driver.

Annex two reference links.

https://www.youtube.com/watch?v=TqUELHnMNSc

http://palel.es/2013/11/12/windows-8-1-hyper-v-sonido-reproduccion-y-microfono-y-otros-recursos-en-modo-mejorado/

I remain attentive to your comments.

regards..
0
rayluvsAuthor Commented:
You mean update drivers in the host computer or in the VM?
0
rayluvsAuthor Commented:
FYI,
Integration Services is installed (see pix below).  But how do I updated it as you suggested?

isrev
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Open Services on the Win7 VM and make sure the Windows Audio Service is set to Automatic and is running.
0
rayluvsAuthor Commented:
It was already set (see pix below)

serv
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Open Hyper-V Manager
Double click on the VM to bring up it's console.
A prompt like this should come up:
Enhanced Session PromptClick CONNECT
Log on.

Sound should be working then as the connection is now Remote Desktop Protocol based instead of Hyper-V Console based which does not do sound pass-through.
0
rayluvsAuthor Commented:
This VM is used constantly.  When the user works with it, always double-clicks on it - the message you are referring to never appears (see pix below).

STEP 1 - choose VM
vmTochoose
STEP 2 - start it
vmAppears
When click "Start", just logs in screen, no messages as you indicate.

FYI on versions info just in case,
The host computer is Windows 10 Pro version:
Version      10.0.16299 Build 16299

The Hyper-V version is:
Hyper-V Manager
Microsoft Corporation
Version: 10.0.16299.15
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Click VIEW in that console:
RDC Enhanced Session
Tick that. Then you'll have sound.
0
rayluvsAuthor Commented:
Thanx ... will do!
0
rayluvsAuthor Commented:
Nope... that line is grayed out.
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Run the following in an elevated PowerShell:

Set-VMhost -EnableEnhancedSessionMode $TRUE

Open in new window


Then check again. Did the above error out or does the setting allow itself to be clicked?
0
rayluvsAuthor Commented:
Will do!
0
rayluvsAuthor Commented:
Ran the line in an elevated PowerShell.  However, Enhanced Session is  still grayed  out.  Will reboot and see.
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
If still greyed out after the reboot then last ditch effort is to remove and re-install the Hyper-V Role.
0
rayluvsAuthor Commented:
Re-installing is a whole different complicated process?
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Apps & features --> Programs & Features --> Add/Remove Windows Roles --> Turn Windows features on or off --> Uncheck Hyper-V --> Reboot.

Run the above and check Hyper-V to install.
0
rayluvsAuthor Commented:
Hi!

Done process and no luck.

Tried troubleshooting the sound via Remote Desktop, no luck (the troubleshooter cannot continue and recommends to connect to the PC instead).

Tried troubleshooting the sound via the Hyper-V console, no luck (says Hardware changes might not have been detected)


So a bit frustrated with this.

Any suggestion?
0
rayluvsAuthor Commented:
Found the solution.

Although "Enhanced session mode" is still "gray out", from within all our search, we found this link that provided the solution.

In essence, this (for more detail we went thru the link):
UseRDPhearSOUND
Note, that in some links we found that we needed to have the VM in Generation 2, but found that with Windows 10, it's not necessary.

Will proceed to close the question and award for you help!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rayluvsAuthor Commented:
Awarded Philp the most for his much followup.  Though Shaun did say "RDP to virtual", there was no detail as to "How" - since we always use our VMs via RDP with no success for sound, we thought that its just connecting via RDP.

Thanx All!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.