RSAT Tools for Windows 10 v1709

I am building a new work computer using Windows 10 Professional build 1709 and am having issues with the RSAT Tools installation.  I went to the Microsoft website and downloaded the Windows update KB2693643-x64.msu file which is the correct file to install the Administration Tools.  The installer installs just fine but when I go into the "Turn on Windows Features"  the Remote Server Administration Tools does not show up in the list to turn on.  I tried uninstalling it and reinstalling with the same issue.  Even rebooted to see if it would show up......no luck.
Eric BrunningDirector of ITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew LeniartEE Senior Editor & Independent IT ConsultantCommented:
Hi Eric,

Problems like this can be highly frustrating, can't they?

I'd first double check to ensure you downloaded the correct RSAT Tools installer for your version of windows by going to this link using the problematic system to check.

I also found a possible solution for you at this link, included below so you don't need to go to the page itself.

----------------------------8<-----------------------------

I had the same problems as ConnorKeyes. RSAT tools installed within seconds, but no tools where actually installed.

After several hours (and getting very frustrated) I found the solution, which worked for me and my colleague:
- Add language as described at the RSAT install page
 - menu start
 - settings
 - time and language
 - region and language
 - add English (United States)
Here comes the trick: You should see something like "Searching in Windows Updates", or "Language pack is available".
- Select English (United States) and click Options
- In the next screen you need to download the language pack for English.
Note: If you do not see any options to download the language pack, the installation of the RSAT tools are not going to work. I know, because I was stuck at this point for several hours.
- Go to Windows Updates and install all available updates. Don't forget to restart (duh)
Doublecheck whether you can choose Start, Optional features. You can continue when you have this app available, because this app also seems to give language pack options.
- Again see if you can select English (United States) and install the language pack.
- Only after the language pack is installed (handwriting and speech are obviously not necessary), you can install the RSAT tools and everything works (again) as designed.

(I installed the Dutch version, so pardon if naming is not completely correct)

Alexander


----------------------------8<-----------------------------

I'd also recommend downloading and installing any Windows Updates that may not yet have been installed, and then reinstall RSAT Tools from the link I provided above once all updates have been installed.

I hope that's helpful. Let us know how you go with the above suggestions.

Regards, Andrew
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
Yes, take Andrew's link. And please be aware that unlike previous windows versions, win10 does not require you to do anything after installing those - all features are automatically available.
0
Eric BrunningDirector of ITAuthor Commented:
I have tried the items described with no luck.  I have the English (United States) as a language and there are no downloads when I select Options.  I also tried adding English (Canada) as a second language and downloaded the language pack for it and still no RSAT.....even after rebooting.  This is so frustrating!  I even tried installing the other 64 bit RSAT tools WindowsTH-RSAT_WS2016-x64.msu.  It also installed just fine but nothing shows up in the list as before.  There has to be an easier way.
0
The Five Tenets of the Most Secure Backup

Data loss can hit a business in any number of ways. In reality, companies should expect to lose data at some point. The challenge is having a plan to recover from such an event.

McKnifeCommented:
What "list" are you looking at? The list in "add windows features", as I told you, will not contain those, since all features are installed by default on win 10.

You will find those tools in the section administrative tools in the classical control panel (winkey+r, launch control.exe), or through start menu search.
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
I can confirm that using the x64 package without any additions installs on a German OS, creates the Start Menu entries, but does not appear in Windows Features. There is no way to get rid of them all or some of them.

Further, as hinted above and stated in the MS download instructions, you need to have one of the supported languages installed in your OS, natively or as a language package (cs-CZ, de-DE, en-US, es-ES, fr-FR, hu-HU, it-IT, ja-JP, ko-KR, nl-NL, pl-PL, pt-BR, pt-PT, ru-RU, sv-SE, tr-TR, zh-CN und zh-TW).
0
Eric BrunningDirector of ITAuthor Commented:
I installed the RSAT tools again and they finally showed up under Administrative Tools as McKnife stated......but I do not see DNS as an Admin Tool......did they rename it or is it no longer available?
0
McKnifeCommented:
See the descriptive text accompanying the download: Due to a bug, DNS is missing. If you want it, uninstall 1709 RSAT and install 2016 RSAT from the same link, instead. It has Dns.msc
0
Miguel Velez-WhiteSr Systems EngineerCommented:
Installing doesn't seem to be the issue; I've likely done it at least 50 times today.  I've seen the various solutions (language pack, extract from cab file, dism, powershell, etc).  So far none of them have all the RSAT features to show up in the Windows Add/Remove feature dialog box.  Not in there, nor in administrative tools...NOWHERE!!..I'm praying that somehow (somewhere) someone has come up with THE solution.  I don't wish to make a 2016/2019 jump server just to have those tools,  Please  help!!
0
McKnifeCommented:
Miguel, what features are missing for you?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.