How to resolve SharePoint 2013 server failed to communicate with SQL Server?

Dear EE experts,

Kindly see the attached screenshot for the error result that we received while we reconfigure our SP 2013. We changed the IP's of our whole company, and our SP2013 got disconnected. So we need to reconfigure it, every time we try our SP talk to our SQL db server to retrieve database names, it shows the db names, but when we try to connect on it, this error is always what we get: "Failed to connect to the existing server farm located at the specified database server and database name. The database name is not a valid configuration database."

Kindly advise what we must do with our SharePoint &/or SQL Server...

Thank you & hope to hear soon...
Capture-2013.png
Stiebel EltronAsked:
Who is Participating?
 
Walter CurtisSharePoint AEDCommented:
Never a good idea to change the IP address on a production system. But I bet you know that now.

Ad mentioned above, check the basics. Before you do anything with the configuration wizard, make sure you have connectivity with the SQL server. This link has a great tip about a tool that I use all the time to check the connectivity to SQL. You can use the "run as a different user" command to test the connectivity with the user account that SharePoint will use to connect to SQL.

https://blogs.msdn.microsoft.com/steverac/2010/12/13/test-remote-sql-connectivity-easily/

If you do not have connectivity, then you will need to check the network. As you mentioned in a different posting, maybe some of the devices new to the network may be blocking you connection. Things such as a firewall or a switch may keep you from hititng the SQL server from the SharePoint server.

Once you have connectivity to SQL, test if  you have Central Administration. Do not run the wizard or leave the SP farm. It will mess things up worse than they already are. This applies to the same issues you are having with your 2007 farm.

Good luck...
0
 
Tahir QureshiSystem AnalystCommented:
it might be caused by that the account you used to log into the server which didn’t have full access to SQL server. an account must have sysadmin, dbcreator and securityadmin rights

is share point and sql are on the same domain?
have you create a dns entry
you may have to log off and log back in to reflect the changes
1
 
Stiebel EltronAuthor Commented:
@Tahir, it was working before, everything's fine and running smoothly, until we changed the IP of our whole system, then mess happened...
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Stiebel EltronAuthor Commented:
@Walter, please see the attached screenshot from the result of our test connection (SP -> SQL Server)

Then what shall we do next?
Screen-Shot-2018-04-12-at-11.26.31-A.png
0
 
Tahir QureshiSystem AnalystCommented:
Check the DNS
And
Firewall  (was it open on a specific IP address )
1
 
Stiebel EltronAuthor Commented:
Follow up to our comment with Walter, we did that test connection with our MOSS 2007, the result is same, "Test connection succeeded".
0
 
Stiebel EltronAuthor Commented:
@Tahir, yesterday, we did that already, first with our MOSS 2007, check the DNS, and even the hosts file, we checked everything and changed the IP addresses, that's why from our MOSS 2007, we run the SP Config successfully, we can open the CA, but the site that we use everyday, some parts are gone, and from CA, the SSA showed error (no connection from SQL). Anyway, please see our other thread regarding to this MOSS 2007.
And with our SP2013, we can't connect with our SQL DB, but when we test the connection, it succeeded...
0
 
Stiebel EltronAuthor Commented:
@Walter, after we test the connection, it has a connection to our SQL, then we test our CA, but it resulted 500 Internal Server Error. Can't access the page...
0
 
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Could it be an incorrect alias?
Open SQL Server Client Network Utility by typing cliconfg.exe in your Run command.
Check if there are any aliases defined for the server you are trying to connect to.
If present, do the following:
*    Click on Edit and rename the Server alias. (for example, if your server name is MySQL, rename it as MySQL_test) and retry the connection. If the connection works, it is an indication that you had an incorrect alias, probably from an old configuration that is no longer needed. If you continue to experience the error, rename the alias back to its original name and proceed to the next step.
*    Check the Connection parameters for the alias and ensure they are correct. Some of the common scenarios that can cause problems with connectivity are:
     *   Incorrect IP address for the Server name parameter. Ensure this IP address matches the entry in the SQL ErrorLog file.
     *   Incorrect Server name in the Server name parameter- For example though your Server alias points the correct server name, if the Server name parameter has incorrect value, connections will fail.
      *  If you are using a named pipes alias, ensure the pipe name has correct format
         *   For connecting to default instance named Mydefaultinstance, the pipe name should be \\Mydefaultinstance\pipe\sql\query
         *   For connecting to a named instance MySQL\Named, the pipe name should be \\MySQL\pipe\MSSQL$Named\sql\query
1
 
Stiebel EltronAuthor Commented:
Hi Mike! Thanks for your response...
>>Open SQL Server Client Network Utility by typing cliconfg.exe in your Run command.
Check if there are any aliases defined for the server you are trying to connect to.<<
- We did that both sides, from our SQL Server and even in our SP 2013 server, renamed the Alias / Server name or return back to its original name, the error still persists...

Kindly see the attached SQL Error log, it's surprising that the 2 admin accounts can't be use to access the db, but receive error...
SQL_Error.log
0
 
Walter CurtisSharePoint AEDCommented:
Hope you have this solved by now. Some very good advice has been given by all. Here is one of your issues:

@Walter, after we test the connection, it has a connection to our SQL, then we test our CA, but it resulted 500 Internal Server Error. Can't access the page..

Since there is a connection to SQL, this may be caused by IIS on the web server. Check to make sure that the app pool is running, or better yet recycle the app pool in IIS. If you still have an error do an IIS reset. This error could be caused the SQL services on the SQL server being stopped. That can be checked on the SQL server directly.

Good luck...
0
 
Stiebel EltronAuthor Commented:
@Walter, thank you for your kind response...
>> Since there is a connection to SQL, this may be caused by IIS on the web server. Check to make sure that the app pool is running, or better yet recycle the app pool in IIS.<<
- Done recycling...

>> If you still have an error do an IIS reset.<<
- Done IISRESET

>> This error could be caused the SQL services on the SQL server being stopped.<<
- Checked the SQL services on SQL server, restarted all related to SQL.

Result: Still 500 Internal Server Error...

Please see the attached screenshots...
Screen-Shot-2018-04-17-at-10.42.08-P.png
Screen-Shot-2018-04-17-at-10.44.22-P.png
0
 
Walter CurtisSharePoint AEDCommented:
Make sure the credentials for the app pools are set correctly. You should do this under normal conditions via Central Administration (does that work?), but in this recovery state you can do it directly in IIS. What you need to do is right click on the app pool named SharePoint - 2018. then you will see a button for advanced settings, and from there you can add the user name and password. Give that a try.

Questions, why is that named SharePoint 2018. I thought you installed your SharePoint farm last year or the year before.

Good luck...
0
 
Stiebel EltronAuthor Commented:
CA is still not working... So attaching the screenshot from the Advance Settings of SharePoint - 2018 app pool.
Where to put the user name and password?

Q: Questions, why is that named SharePoint 2018. I thought you installed your SharePoint farm last year or the year before.
A: It's because we started to setup SP 2013 since last year 2015, then we tested some stuffs from virtual player, and we've used several ports already until we come up with SharePoint - 2018 (our latest one)...
Screen-Shot-2018-04-17-at-11.47.06-P.png
Screen-Shot-2018-04-17-at-11.47.29-P.png
0
 
Walter CurtisSharePoint AEDCommented:
Look at the first screen shot. About half way down is a section titled "Process Model". The first entry in the section is "Identity". Click on the entry and it should open so that you can reenter the username and password.

I understand about where the name came from.
1
 
Stiebel EltronAuthor Commented:
Though we're not yet done with this, we would like to reward points to the closest and give us idea in some parts... Thank you!
0
 
Walter CurtisSharePoint AEDCommented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.