KVM Switch speed slow on return to PC only one IOgear but not another, why?

I have 3 IOGear KVM Switches.

The first swaps out from my PC to my laptop almost immediately. Going back it takes about 3-5 seconds.

The second two take anywhere from 20 to 30 seconds swapping back to the PC. But going to the laptop is a few seconds again.

My laptop is:
Intel Core i7-7700HQ CPU @ 2.81Ghz 2.81 Ghz
16.0 GB RAM
64 bit OS, x64-based processor
Windows 10

My PC is:

Intel Core i7-4790 CPU @ 3.670Ghz 3.60Ghz
32.0 GB RAM
64 bit OS, x64-based processor
Windows 10

My question is: Why is it so much slower on the return trip from the laptop to the PC on one IOgear and not the other?

I don't want any guesses, as I'd like a response from someone who knows about these things, because I can guess that returning to the PC is slow because the CPU is older, but I don't know why one switch would be faster and 2 slower.

I'd like to hear from someone who knows, if that person exists on here.

Thanks!
LVL 2
Starr DuskkASP.NET VB.NET DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NerdsOfTechTechnology ScientistCommented:
Hypothesizing (educated guessing) is part of practicing any science (medicine, technology, etc.) so I will go out on a limb here and be the first to answer. *Gulp*

The inherent HDMI sync delay (make sure you are running the same resolution, if you can) and sleep/power settings are likely culprits to the delay difference.

Power settings: Note: with these settings, it is advised to make sure a screen saver is on for both systems. Check to see if either system is set to "turn off screen, in X seconds" and make sure that is set to "never" (last option).  For the laptop you'll change both plugged in and not plugged in settings. Do the same for "sleep, in X minutes" to "never". In advanced power settings, you want to make sure your hard disk on both systems isn't shutting off either after X minutes (set to never). Also turn off USB selective suspend (toggle it to disabled). On the laptop, you might want to change cooling to active as well (fan on full time to compensate for the heat from the CPU and hard drive being active full time).

The bigger delay issue is self-evident: one KVM (Keyboard Video Mouse) switch worked quicker than the others. From this information, I recommend that you to test out additional brands that meet your requirements if you are trying to replace that faster KVM switch with a new one; for example, the following Trip-Lite HDMI KVM switch (hotkey); excellent ratings and seems to have a (normal) 3-5 second switch delay:

https://www.amazon.com/Tripp-Lite-Peripheral-Sharing-B032-HUA2/dp/B072LBN7L8/ref=sr_1_5?s=pc&ie=UTF8&qid=1524084354&sr=1-5&keywords=hdmi
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
For anyone looking for info on the above mentioned disabling selective suspend:
https://www.windowscentral.com/how-prevent-windows-10-turning-usb-devices

Thanks for the info. I'm returning the 3 I have and going to try the TrippLite.

I tried all your suggestions and it seems to have made the wait even longer! LOL.

I'll let you know when I know more.
1
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
I did return my 3 iogears and purchased the Tripp-Lite.

It looks almost exactly the same as the Iogear. I suspect it's made by the same company with different branding.

The hot-keys and the method of disabling the mouse and keyboard are the same if you are using USB 3 keyboard and mouse.

And it functions exactly the same as far as speed and switching.

I guess I'm keeping this one, because I've got to have something, but the 30 second wait when returning from the laptop is annoying.

Disabling selective suspend actually made the time take longer for both the iogear and the TrippLite.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

NerdsOfTechTechnology ScientistCommented:
Try setting both systems' resolution as the same.

What about shorter HDMI cables? (or replacing cables)

Any change to switch speed?

Also, are you connecting to an LED TV or monitor?
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
Both do have same resolution.
I am using a TV as a monitor.

I do have the power settings as you suggested already.

I have a short cable on this tv/monitor already. So I just tested swapping out to the other tv/monitor. It has a longer cable, but it is brand new.
Same thing. 40 second wait.

I already have a USB 2 mouse on here but the keyboard is USB3. I'm going to test with a USB2 keyboard and see if that is the culprit.
0
NerdsOfTechTechnology ScientistCommented:
Does your TV have a "game mode" or similar setting? Sometimes this removes much of the post-processing of the input (which might be causing the lag)

Is the TV set for auto color or similar setting? Try setting this to a manual color setting.

Next, try setting the systems to a native resolution (e.g. if TV is 1080p use 1920X1080 60hz)
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
I use 1920x1080.

The mode is PC Mode. You're saying NOT to use game mode, right?

Picture Mode was Entertain. I'll try Standard. But I found nothing about Auto Color.

It took 40 seconds to have access to my keyboard.
0
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
I tested with a USB 2.0 keyboard and it comes up in about 6 seconds returning from the laptop.

I installed the USB3 keyboard and used just one of the two connectors and noticed that the one I chose didn’t work at all. So I used the other one and it worked.

You'll see there is no consistency on test results:

Times are for return from laptop to pc. Pc to laptop is always 5 seconds-ish.

Test 1:
11 seconds for the mouse to activate
30 seconds before the keyboard activated
(I had been on laptop for several minutes)


Test 2:
10 seconds for keyboard and mouse
(I hadn’t stayed on laptop for more than a few seconds)

These tests:
(after clicking for immediate return from laptop, how long before keyboard and mouse activated)


Test 3:
34 seconds for mouse
39 seconds for keyboard

Test 4:
Turn off keyboard lights.
10 seconds for mouse
30 seconds for keyboard

Test 5:
10 seconds mouse
29 seconds keyboard

Test 6:
Turn on lights again.
35 seconds both keyboard and mouse.

Test 7:
15 seconds both.

Test 8:
11 seconds

I'm just going to close this ticket. Thank you for all your assistance.
1
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
thank you! I guess it's just inconsistent and I'll have to live with it.
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.