Can you Help me to Read Mail using PL/SQL

i have custom Mail Server. i want to reed my email using pl/sql Procedure. i am trying with MAIL_CLIENT Package but facing issue with Host name and Not connecting.
Can you help me with any Option to Read Mail using pl/sql.
LVL 1
Pradeep komariSystem AnalystAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mark GeerlingsDatabase AdministratorCommented:
PL\SQL is designed for processing data that is in Oracle databases.  Trying to use PL\SQL for something it was not designed to do may not be your best option.

I've never used the MAIL_CLIENT package, so I can't help you with that.

It may be easier for others to help you here if you describe the problem or error you see with the host name, and if you give us some information about: "Not connecting", like what exactly is not connecting to what?  Do you get an error message?
1
Pradeep komariSystem AnalystAuthor Commented:
Hi,

MAIL_CLIENT Contains Java Methods to Fetch the Data from Mail Server.
Link: http://plsqlmailclient.sourceforge.net/apidoc/index.html
in that  we have a Method initially to connect/ Login to the Server from Back end.
i.e.
  mail_client.connect_server(
  p_hostname => 'mailserver.mydomain.com',
  p_port     => 143,
  p_protocol => mail_client.protocol_imap,
  p_userid   => 'user.name@mailserver.com',
  p_passwd   => '***',
  p_ssl      => false
);
Not Connecting:
We are getting errors as (Unknown Host name, Network Not Reachable, No Route To Host Exception)    So, that we are finding Other way to fetch the Data from Mail Server.

Thanks,
Pradeep.
0
slightwv (䄆 Netminder) Commented:
I assume you have confirmed the database server can talk to the mail server on that port and this isn't a simple network issue.

Did you follow the installation instructions and perform the dbms_java.grant_permission steps?

http://plsqlmailclient.sourceforge.net/FAQ.txt

Depending on your version of Oracle, you might need to set some network ACLs: dbms_network_acl_admin.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Pradeep komariSystem AnalystAuthor Commented:
Yes slightwv,  i granted the permissions and  i am trying this from admin User..

in between i tried in other way i.e.
build a Mail Server in Cloud instance.
in the Same instance i added Database, in that database i installed Mail_Clint Package and tried connecting.
with this scenario we solved the Unknown Host issue but we are facing Another issue i.e. "ORA-29532: Java call terminated by uncaught Java exception: javax.mail.AuthenticationFailedException: [PRIVACYREQUIRED] Plaintext authentication disallowed on non-secure (SSL/TLS) connections. " while running the Procedure Connect Server.

can you Explain me what Exactly we need to do to setup network ACLs: dbms_network_acl_admin.
0
slightwv (䄆 Netminder) Commented:
>>Plaintext authentication disallowed on non-secure (SSL/TLS) connections.

In the connect_server call, I would take a look at:  p_ssl - SSL flag - defaults to false.  Possibly set it to "true"?

Sorry but I cannot provide exact steps you need to take because I don't have a system setup similar to yours to test.  I can look at the documentation you provided and errors you are receiving and make some guesses at what might be causing issues.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pradeep komariSystem AnalystAuthor Commented:
Thank you slightwv.

we tried that option Already but we need certificates for that. it checks the certificates at that time.
than we get another type of error like "No Certificates found.."
0
Pradeep komariSystem AnalystAuthor Commented:
we got the correct Solution from other source.
Actually the problem is located at Mail Server configuration in Linux.
we don't have the parameter "ssl" in configuration file.
we must declare that parameter as no for this type of error.

Thank you all.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.