can't figure out why a homegroup cannot be joined

setup a homegroup with 4 computers (windows 7 Pro)  Every few days everything stops working.  Multiple erros.  Link won't work or when you go into the shortcut for a shared folder on the computer that created the homegroup there is nothing in there.  Has to be something in the office where the computers are.  I have NEVER had an issue like this.  So, now I decided to start from scratch.    I left the homegroup on all the computers so yesterday they said create a homegroup.  Now this morning it shows that the 1st computer I created the homegroup for needs to join the homegroup.  Not sure if you can uderstand what I' saying.  I didn't create another homegroup on this pc but it says I need to join it.  It's asking the computer that created the homegroup to join the homegroup.  When I try to do this I can't.   Errors out.  That is where I will start on this issue.
mkramer777Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fred hakimRetired ITCommented:
These sorts of issues is why I never use homegroup.  If all you need is access to data between PCs, I find using standard windows networking to be the easiest.  

Make sure all computers are in the same workgroup, check by right clicking properties on my computer or this PC icons.

Then go to  Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings
In there, configure your home network on each computer.  The options are self explanatory, but a few key items:  
     turn on network discovery
     turn on printer and file sharing
     turn on sharing for folks with network access
     If its a private/secured network, turn off  password protected sharing
    Allow windows to manage homegroups

At this point your public folders will be visible.  You can go to any other directories you want to share, open properties, and select the sharing tab. it provides options for who and how to share the directory (and all its sub directories).     Alternatively, you will probably notice a "share with" item on the right click menu.  It will also work, just fewer options than properties.   I usually select  [everyone] from the drop down, so all my PCs have access to the directory.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joinaunionCommented:
What error are you getting?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.