• Status: Solved
  • Priority: High
  • Security: Public
  • Views: 63
  • Last Modified:

virtual machine goes off with space issue error

Hi,

I have four ESXi Servers 6.0 connected Dell Equallogic SAN. some of the vm's start giving error that There is no more disk space, please find attached also. whereas there is space now.

i googled and found some solutions related to snapshots, i didnt' have any snapshot. so i created one snapshot and delete all. still it didn't fix the issue. i have even migrated to different servers but the issue is same.

Please advise.
space-issue.png
0
MCIT-Libya
Asked:
MCIT-Libya
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
The screenshot posted is because you have VM running on a snapshot

Please check the VM folder NOT snapshot manager for files which are snapshots

Also check these VMs are not being backed up by third party backup products which have left snapshots or still have the parent disk locked!
0
 
R@f@r P@NC3RVirtualization SpecialistCommented:
Hello,

- Examine the datastore where the vm is stored.
- Search the folder of the affected vm.
- Validate that there is no snapshot present in the folder of the affected vm

If there are snapshots present, share an image, it may be that an instant is writing on the base disk.

Regards...
0
 
Ajay ChananaMCSE-2003/08|RHCSA| VCP5/6 |vExpert2018Commented:
To have the above Solved, please increase the datastore space where you have this VMDK.

once the space is increase you can power on the VM , also delete the snapshot via consolidation option.

consolidation option- (this option will delete the snapshot which is not visible in snapshot manager.)
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
MCIT-LibyaAuthor Commented:
Thanks everyone for helping, but the issue was not from snaphots as i already deleted all. the issue came out to be from the SAN. Since the equallogic was configured as thin provision. The issue is that whenever you write in the san and then delete the san still think that delete operation as write and does not delete those blocks.

to fix this you have to reclaim space from the vmware by using shell of ESXi.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Close question and select your own answer!
0
 
MCIT-LibyaAuthor Commented:
I managed to fix by following this article:

https://kb.vmware.com/s/article/2057513
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now