Error: 0x80073701 When adding Remote Access Role in Server 2016

Hi all, really need some urgent help please.  I have a brand new Dell server that I have set up with a domain controller using Server 2016 Standard running as a Hyper V. I've spent the best part of a week setting it up and at the last minute was asked to add VPN access, so I went to add the role in Server Manager and it gets about half way through then fails with Error: 0x80073701.  

I've googled it and there are some articles about missing language packs but I can't really make sense of the suggested fix (removing fr_FR and de_DE keys from  bits of the registry). I could really do with someone guiding me through fixing this as it's causing a lot of grief.  Steps I have taken so far:

Run DISM.exe /online /cleanup-image /restorehelath
Run SFC /Scannow
Removed Antivirus software (just in case)
Restarted
Logged on as a different admin user

Would be very grateful if someone out there could help me please!

All the best

Adam
Gavin ReidAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Are you running a DC as a hyper v host also?

Is the operating system up to date?

Try pointing the roles and features at the installation CD directory see if that helps.

Anything relevant in application or system log under critical, warning or error?
0
Gavin ReidAuthor Commented:
Hi Mark,

No the virtual DC does not in itself have the Hyper V role installed on it. Operating System is up to date as at 2 days ago.

I've just tried installing the role and clicked option to install from a different source and pointed to CD drive and this failed with the same error code I'm afraid "the referenced assembly could not be found error: 0x80073701

Events of note are:

(System) Error Event 20063, Remote Access - Remote Access Connctoin Manager failed to start because the Protocol engine (rasgreeng.dll) failed to initialize. The specified module could not be found

(Application) Information Event 1001 Fault bucket, type 0 Event Name: CbsPackageServicingFailure2 Response: not available

(Application) Information Event 1001 Fault bucket, type 0 Event Name: WindowsWcpOtherFailure3  Response: not available

Thanks
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
I assume you mean this? https://community.spiceworks.com/topic/1974434-server-2016-unable-to-add-roles-or-features-after-making-server-a-domain-control

Have a look in CBS.log see if you see the same errors he mentions, first confirm it is the same issue.

You posted a CBS error from the event log right?

Are you doing a windows update against WSUS? if so do it against the internet there is an option in updating for that.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Gavin ReidAuthor Commented:
Hi yes it's the same as that link you sent but I just don't know what I am looking for in the CBS log, there are literally thousands of entries in the log just for the last few hours. I'm doing Windows Update just by clicking Settings then Update and Security
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
have a look for updating over the internet option, or against microsoft site wsus site.

try opening that log with notepad++ , log files are bad enough as it is notepad++ will improve reading comprehension, sift through it for errors, then I would take a backup of that box and check out the reg keys the user refers to in spiceworks link.

I would get a full windows update done first to be honest, this sounds like a bug.
0
Gavin ReidAuthor Commented:
I've just downloaded and run all the updates available for the very latest Windows 2016 and they all come up saying they are not applicable to my computer (which I'm taking to mean they are already installed..
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Ok if your sure its up to date NP

What about the CBS log? Any luck there? that is a key area of windows OS / Windows Updates / Internal Database AFAIK.
Resolve any errors you find in there as best you can.
0
Gavin ReidAuthor Commented:
I have found errors in the CBS log relating to a number of languages, namely JP, KO, ES and FR so I'm going to try and install those languages, otherwise it looks like the solution is to go to HKLM\Software\Microsoft\CurrentVersion\Component Based Servicing\Package Detect and find all keys relating to those languages and remove them, but to do this you have to take ownership and disable inheritance on each one before being able to delete and looking at the list there are literally hundreds of entries so that is just impossible aaaargh!
0
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Ok sorry for late response, I am working on some Fing problem for 5 days now :( cry

Delete them and follow the lead from that Spiceworks link is my advice. Obviously take backups first when going reg level on servers.

Good luck, the world of CBS in windows is pretty crazy, I know that from a few horrible issues I dealt with before. Things can get very buggy and messy IIRC in these areas.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gavin ReidAuthor Commented:
Thanks Mark, I have just finished deleting all the registry entries for language KO_kr and it's now working! Thanks very much for your help and good luck with your FING problem!
1
Gavin ReidAuthor Commented:
Thanks
1
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
lol thanks it really is an absolute fucking nightmare, dev level problem and i am not dev.

have a good day.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2016

From novice to tech pro — start learning today.