hyper v cluster storage

hi guyss,

i stucked in very bad situation, the vm has been restarted and the virtual storage attached in the machine was discinnected.

i tried mount that vhdx file but i faced error.. atlast i shutdown vm and tried to turn it on it shows error (attached)

i understand that the issue is the vitual storage file is mounted somewhere so i cant access it to start my vm..

could anyone tell me how to kill that process to access this vm file
LVL 1
Azarudeen MohamedSystem EngineerAsked:
Who is Participating?
 
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Maybe your VHD file is just locked? and not mounted?
Have you tried to restart the server which could undo a lock or reattach storage safely?

Is there a backup running locking the file perhaps?

So you have a file server, and you cannot attach one of its VHD files correct?
If so do any other VMs use this file?
Where is the storage located physically?
0
 
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
What is the error I cannot see attachment.

Are there any VMs running succesfully at the minute?

Any critical, warning or errors in application or system log on hyperv host?

What does HyperV BPA say when ran on host?
0
 
Azarudeen MohamedSystem EngineerAuthor Commented:
whike adding cluster storage andbclick on inspect

the process cannot acess the file because it is being used by another process


it is 100 percent that particulat vhdxfile issue i guess
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Try doing a full windows update against the internet site, all optional included which will update your drivers.

maybe this ? https://support.microsoft.com/en-ie/help/2000800/an-error-occurred-while-attempting-to-start-the-selected-virtual-machi

this ? https://social.technet.microsoft.com/Forums/windows/en-US/68c8a7c3-6a99-496f-b94f-86e7a195884f/the-process-cannot-access-the-file-because-it-is-being-used-by-another-process-event-id-489?forum=windowsbackup

Can you post the results of a BPA but more importantly critical, warnings and errors from event log that are relevant?
0
 
Azarudeen MohamedSystem EngineerAuthor Commented:
hi mark, thx for the commEnt...

the issue here is different everything is ok thr machine is running fine once i removed particular vhdx file (file server)

if i attach thst file it shows that vhdx file is using by someother... so i just want to dismount the vhd file but i dont know where it is mounted
0
 
Azarudeen MohamedSystem EngineerAuthor Commented:
This has been fixed,

I know this is not the solution for this but for make it faster i done this.

I have just copy and paste the same file to different location, then i attached that new vhdx file in hyper-v settings. it got fixed.
0
 
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
the file is just locked. unlocker would provably do the trick. hooing for the points anyway.

nice workaround  m
1
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.