• Status: Solved
  • Priority: Low
  • Security: Public
  • Views: 59
  • Last Modified:

Add a self-hosted MS Exchange account to Windows 10

Hello, I was wondering if there truly is a way to add a self-hosted Exchange account to Windows 10.

In Settings/Accounts/Email & App Accounts there is an Add Account button which supposedly allows you to add and Sync many kinds of account: Google, Yahoo, iCloud AND Exchange.

They all work, except for Microsoft's own Exchange??

Here's what I try to do: I use advanced settings to add an Exchange Active Sync account (we're using Exchange 2016).

I get the following form:



So I enter all required data, which I entered in a gazillion other interfaces on Android, on Outlook, on Thunderbird (with DavMail) and more, and they work everywhere.

Microsoft's own OS seems to accept the data, but then it doesn't sync anything. I just need to sync the calendar, but it just won't work. It stays stuck trying to sync, then just gives up.

No error whatsoever in Windows events, either. I'm totally flabbergasted.
0
Daniele Brunengo
Asked:
Daniele Brunengo
  • 4
  • 2
  • 2
  • +3
5 Solutions
 
JohnBusiness Consultant (Owner)Commented:
Try the following:

Go to Control Panel , Mail, open email accounts there and set up the Exchange Account manually.

Please let us know
0
 
Daniele BrunengoIT Consultant, Web DesignerAuthor Commented:
That's not what I want to do. That's what you do to add the account to Outlook. I want to add it to Windows 10 and the two things are separate. I already added it to Outlook with no problems, but I'd rather use the Windows calendar app than Outlook's calendar. It should sync, but it doesn't.
0
 
JohnBusiness Consultant (Owner)Commented:
I think you might run into a conflict using the same account in Windows Mail as Outlook. I suggest you use the Outlook Calendar as it works perfectly and syncs with all major devices.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Cliff GaliherCommented:
My guess is that you have an issue with how auto discover is configured on your exchange server and/or certificates used. Yes, the windows 10 mail, people, and calendar app suite syncs with exchange 2016. Yes I have personal done this. And no, it won't conflict with exchange.

When syncing fails, it is usuallg a configuration issue. Many 3rd party apps don't rigorously check settings.or certificates (for a valid CA or revoke status) and are therefore more forgiving. And more insecure.

After the beating Microsoft took in the late 90s on windows security, they tend to be very strict on valid settings or setup and use fails.
0
 
Aaron GuilmetteTechnology Solutions ProfessionalCommented:
More than likely, you need to check your on-premises autodiscover configuration.
0
 
McKnifeCommented:
Often, the wizard configuration is kept very basic and there are advanced settings that you can only get into after finishing the wizard. So please compare those to the settings which might ´be the default in thunderbird and co.
0
 
arnoldCommented:
The path to the server, require SSL might be your issue.

It is difficult from just looking at the interface point to where the discrepancy in the information you provide that causes a mismatch in your environment.

Check the configuration settings in outlook, and match them to the information you provide in the mail app interface.
0
 
Daniele BrunengoIT Consultant, Web DesignerAuthor Commented:
It's an SSL problem for sure, I think Cliff is right. Android allows you to accept any certificate, you don't get options in Windows 10 though. There must be strictest rules, I still find it strange that EVERYTHING works except for Windows 10 integration.

Since I basically hate Outlook, I found another calendar app (One Calendar) in the MS Store, very basic but light and has all the features I need. And of course it does work with our server. Go figure.
0
 
arnoldCommented:
if you use a self-signed certificate, add the public portion as trusted by your windows 10 and you resolve the issue.
using a browser go to https://yourexchange:465 and look at the cert and import it as trusted. once it is trusted in your user's store it will be trusted ....
0
 
Daniele BrunengoIT Consultant, Web DesignerAuthor Commented:
If I visit that address I get an "address is locked" warning.
0
 
Daniele BrunengoIT Consultant, Web DesignerAuthor Commented:
Anyway, I decided to use a third-party app which works great.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 4
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now