• Status: Open
  • Priority: High
  • Security: Public
  • Views: 62
  • Last Modified:

get error message when trying to create virtual domains in wampserver

I am trying to create a virtual domain in wampserver, when i try to create one in the "Add a virtualHost" panel i get the message "c:/users/edkna/desktop/allsites/site1 does not exist or is not a directory", even though there is a directory there.
I tried creating a directory in multiple places on my computer (which i have full admin rights to) I am carefull to correctly copy and past the path to the directory and paste it into the "complete absolute path of the virtualhost" field but I get this error message every time. (see the attached screen capture errorMessage.JPG)

Also another issue that is probably related to the above issue, when I tried to add a second directory in  C:\wamp\www  for a another Wordpress site, I get the following error messages:
( ! ) Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0
( ! ) Fatal error: Unknown: Failed opening required 'C:/wamp/www/site2/index.php' (include_path='.;C:\php\pear') in Unknown on line 0 (see the attached screen capture anothrErrorMessage.JPG)

Can you tell me how to fix this problem?

Hi Dave,
 you said it could be a permissions issue.  Properties/Security show I have full control.  This is also my personal computer which I have all privileges to. are you referring to some other permissions that I am not thinking of? I was able to create virtual domains six months ago, so I don't know of any thing that is different on my computer now.

Hi noci,
 I pasted in the path with "\" but the wampserver error message converted the "\" to "/"

I have had no problem creating virtual domains in the past (six months ago) for some reason now I am getting this error message.
errorMessage.JPG
anotherErrorMessage.JPG
0
Ed Knack
Asked:
Ed Knack
  • 2
3 Comments
 
Dave BaldwinFixer of ProblemsCommented:
You may be encountering a permissions problem on the first item.  I didn't have any trouble creating a 'site2' subdirectory and virtual host.
0
 
nociSoftware EngineerCommented:
Windows need \ not / ...
0
 
Dave BaldwinFixer of ProblemsCommented:
Noci, the WAMP software converts the \/'s properly.
0

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now