MS Access Macros keep disappearing.

We have a server using an Access Database as the "back end" for a simple web query form.  The clients have no access to the database at all.  About once a week, the macros totally get deleted and we have to put them back.  We have set the "allowed locations" for macros and allowed macros to run in the Access Database Options.  Everything was working fine for over a year and just about a month ago, the macros started getting deleted at least once per week.  What could be causing this to happen?  They still exist in the system but the front end application stops functioning and we have to re-import them.
marshaweinmannNetwork ManagerAsked:
Who is Participating?
 
John TsioumprisSoftware & Systems EngineerCommented:
How about compiling the Access
0
 
Dale FyeCommented:
Rather than reimporting the macros into the existing FE, why don't you simply copy the master database and use it?

Or better yet, create an application launcher (generally a bat file) which will copy the master database onto the users computer and launch it, every time they run the application launcher.

Dale
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
Are you using Access as the Frontend? You mention a web query, so are you instead using Access with a web page of some sort?

What do the macros do?
0
 
marshaweinmannNetwork ManagerAuthor Commented:
Hi

The Macros update the backend database.  The users only interface through a web portal.

Thanks
0
All Courses

From novice to tech pro — start learning today.