Help with Exchange 2013 Rule

We have added a former employees email address as an alias in the manager's list of email addresses.  The former employees Exchange account has since been deleted.  How can we create a server based rule (Exch2013) that tags the subject line with the phrase "Fowarded" on messages that are sent to the former emps address?  Currently the To: information is lost once the message is delivered to the manager's inbox.  We don't want to keep the Exchange accounts for former employees past a certain timeframe so we simply add their address as an alias instead.

We have tried "If the message includes these words in the recipient's address 'firstlast@ourdomain.com" do the following: "Prepend the subject with 'Text goes here'", Rule mode is Enforce and additional properties: "Sender address matches: Header".  Doesn't work.  We have also tried if the message header contains 'firstlast@ourdomain.com' do the same, but this also doesn't work.

Any suggestions would be appreciated.  Remember the recipient (former emp) is no longer available to pick from when using "Apply this rule if the recipient" "is this person".
rob 777Systems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

timgreen7077Exchange EngineerCommented:
Try to add the AND condition, and for "Apply this rule if the recipient" "is this person" select the manager who now has the address tied to him email proxy addresses.

What you have looks good just add "If the message includes these words in the recipient's address 'firstlast@ourdomain.com" AND "Apply this rule if the recipient" "is this person" then do the prepend and so forth.

try that and see if that will help you.
0
systechadminConsultantCommented:
Hi ,

Please try the attached rule in Exchange, you might need to create Mail Contact so that rule should pick that email
HTRule.JPG
0
rob 777Systems AdministratorAuthor Commented:
Thanks timgreen7077, really thought you had the solution but still doesn't tag the subject line.  Used 'The recipient is:' manager@domain AND 'Any recipient address includes:' formeremp@domain, 'Do the following' prepend the subject of the message with 'forwarded'.
rule.JPG
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

rob 777Systems AdministratorAuthor Commented:
Gaurav Singh thank you for the suggestion and sample rule where you have added a contact but we were hoping to not have to retain former employee addresses in Exchange.  This would probably work though.
0
timgreen7077Exchange EngineerCommented:
Try this link. This looks like it may work. test and let me know. Of course fit it to your needs but the header part may work.

https://365lab.net/2014/01/02/quick-tip-mail-flow-rules-for-alias-email-addresses-in-exchange-online/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rob 777Systems AdministratorAuthor Commented:
timgreen7077 the disclaimer rule does work but of course it's located at the very bottom of the email and will probably not be noticed by the manager.  I sure wish we could figure out how to tag the subject line.  Thanks for all of your help.
0
timgreen7077Exchange EngineerCommented:
Did you also try to tag the subject line, or just the disclaimer?
0
rob 777Systems AdministratorAuthor Commented:
Works! timgreen7077 In error I had previously left the *Do the following* portion of the rule set with the option "Apply a disclaimer to the message".  It's been changed now to "Prepend the subject of the message with...." **FORWARDED MESSAGE** and works perfectly.  Many thanks for your help, it's really appreciated.
0
timgreen7077Exchange EngineerCommented:
Awesome. Glad to assist.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.