I had to bitterly accept an expert comment recently, J/K
..Implying that my usage of CamelCasing in my code was lame, and I should use underscores.
My personal feeling was that camelCasing was easier to read, less long, but this article below confirms the expert opinion, underscores are better!
So I grudgingly_accept! j/k