runtime error 3035

Using Access 2016 - Microsoft 365 Enterprise E3

Receiving runtime error 3035 (see attached) on a database - it runs fine on my desktop but has an error on laptop.

Checked avaialable disk space and that should not be an issue

Added this code and I still get the error

Private Sub Form_Load()
    DAO.DBEngine.SetOption dbMaxLocksPerFile, 1000000
End Sub

Any suggestions how I can trouble shoot - is this possibly a RAM issue?

Thanks
Error-Message.JPG
rogerdjrAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dale FyeCommented:
Have you determined what operation is being executed when this error occurs?

I recently had a simple Append query which was appending 170K records from a linked Excel File which gave me a similar error.  I had MaxLocksPerFile set to 500,000.  The only way I was able to get rid of this error was to split the query in half (generally), loading the first 100K records, followed by the remainder.

Have run into several other posts on various boards lately regarding this error as well, but none of them have been consistent regarding when the error occurred or what caused it.
0
rogerdjrAuthor Commented:
best i can tell its a computer memory problem - no issues on the desktop computer only when i migrate to the notebook

May also be a windows issue desktop is windows 8.1 notebook windows 10

Is there any way to trouble shoot

The code stops when updatiing a small table
0
Dale FyeCommented:
The couple of other people I've discussed this with have all had to find workarounds.

For example, one implemented a loop and instead of executing a SQL statement used the .AddNew / .Edit and .Update methods of the recordset to add new records or edit existing ones.

Like I mentioned above, I was able to simply break my query into two parts so that it only attempted to append about 100K records at a time.

I don't know what was causing it, but after I attempted  the queries, I had to close Access and reboot in order to reclaim physical memory, so I know something is going on.  Simply closing Access did not free up hardly any of the memory that was consumed when the query ran and I got the error.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SysToolsData Expert - Recovery,Backup,MigrationCommented:
Hi,

This is one of the strange errors comes when you write a lot to a backend database that can't keep up with the management of the lock file.

The solution is to make sure you keep a connection open to the back-end database from each of your clients and that you hold onto that connection until you close the client.

Ref:-https://www.experts-exchange.com/questions/29037081/Hotfix-for-System-Resource-Exceeded-error-in-Access-2016.html

Hope this will help you out.

Thanks
0
rogerdjrAuthor Commented:
Still searching for a solution

I'll reachout to Microsoft tomorrow

Seems to be related to Windows 10??
0
Dale FyeCommented:
Have you been able to isolate what is causing this error?

Is it happening when you get to a particular step or in a particular procedure?  You might want to insert a bunch of debug.print statements throughout the procedure that this occurs during, so you can see where in your code the error is occurring.

Dale
0
rogerdjrAuthor Commented:
No luck isolating the problem seems to happen when editing data on most forms - tried entering this commandat the on load command of the main form DAO.DBEngine.SetOption dbMaxLocksPerFile, 1000000

Wish there was a way to see what is happening with memory while processing to see if its a glitch or a true hardware memory issue
0
rogerdjrAuthor Commented:
Microsoft found the solution o ffice installed on the laptop was 32 Bit

Office installed on desktop is 64 bit

Did a thorough uninstall and reinstalled 64 bit office 365

Problem solved
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rogerdjrAuthor Commented:
Problem solved
0
rogerdjrAuthor Commented:
Found the ultimate solution by calling Microsoft help - other suggestions were helpful in narrowing down the problem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Databases

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.