Link to home
Start Free TrialLog in
Avatar of iamuser
iamuser

asked on

Deploying Windows 2016 RDS FARM Help needed

Deploying new 2016 RDS farm

The following are in place

  • 1 Connection broker
  • 1 RDHS
  • We are not pushing remote apps or allowing outside RDS connections directly to the FARM. So RD Gateway and Web Access is not configured. RDS will be used internally only for now
  • Domain\users are added to the RDHS and Connection Broker's remote desktop group
  • A DNS record of remote.internal.company with the IP address of the connection broker

When i tested with a standard user account, using the address remote.internal.company, I log directly into the connection broker. I do not get directed to the RDHS. I'm not sure why it's not redirecting me

Am I supposed to have the DNS record point to the RDHS? I'm not sure what I am doing wrong
Avatar of Cliff Galiher
Cliff Galiher
Flag of United States of America image

Install and use RDWA.

The issue is that  in 2012 and later, RDS introduced the concept of "collections." You need to define the collection in server manager. And then when you connect, the collection name MUST be specified for the connection broker to properly redirect.

And... Drumroll... The GUI does not provide a way to find or specify what collections re in your environment. Microsoft decided to use RDWA for that... Even internally.

If you use RDWA, the dot-RDP files it generates have the collection name property specified and properly formatted and things work. The only other way to do this is to manually save then edit an RDP file in a text editor like notepad. Which gets ugly fast.
Avatar of iamuser
iamuser

ASKER

The collection is set in server manage with the 1 RDHS.

For 2008R2 our users are using RDP and connecting. Very simple. Okay so the options here is to use RDWA or manually edit an RDP file.

How do the clients get access to the RDWA? Is it via a web browser then?
Web browser  or add the feed to the modern windows 10 app or add the feed to the remote desktops and apps control panel setting. The feed is an xml file served up by RDWA.
Avatar of iamuser

ASKER

So they just made the RDP client useless for Remote desktop services

I tried look for a how to guide on editing the normal RDP client to allow it to be used with the farm but I can't find anything; Do you happen to know where I can find this info?
So they just made the RDP client useless for Remote desktop services

How so?  The Remote Desktop Client has *always* been driven by a set of RDP settings.  Whether you open it and manually type in a bunch of memorized settings, or distribute .rdp files saved from the GUI, or distribute .rdp files downloaded from the RDWA website, or launch from an .rdp file pulled from an XML feed...its all still ends up being the RDC.  In a brand new 2016 RDS environment, with a collection of session host desktops, published via RDWA, and subscribed to in Windows 10's control panel...you see the remote desktop in your start menu...click it...it launched an .rdp....in the TRADITIONAL RD client.  How is that useless?

Useless is a very strong word.  The workflow has changed (but creating a 'farm" changed to "collections" too...so "change" is inevitable.)  This is just another change.  You learn to work with it.  Or you choose a different solution (Citrix is still around, and Citirix Receiver is a perfectly valid endpoint client that many businesses love.)  I'm not telling you that you HAVE to use remote desktop.  You just asked why you were connecting to the connection broker instead of getting redirected.  The answer to THAT question is because you aren't using the workflow as intended.  RDWA is an intentional part of that workflow now.
SOLUTION
Avatar of iamuser
iamuser

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of iamuser

ASKER

I have wildcard SAN's and I'm not against securing it. And currently the certs are installed

Ex. I downloaded the client from the RDWA portal, I went in and edited RDP file, changed the FQDN of the connection broker line from broker1.internal.company to FARM1.internal.company. (I have a DNS record of FARM1.internal.company pointed to the IP of the connection broker). Running client now shows me FARM1.internal.company. Which is much nicer and the connection is still secure due to the wildcard cert. I'm not seeing a way to do the same directly from the RDWA
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of iamuser

ASKER

great thanks