Any known fix for slow upload speed using Fios Quantum G1100 Wireless Router

I installed a Fios Quantum Gateway G1100 Wireless Router over the weekend.  Wireless is strong, 58-61 mbs down and up. Problem is my vintage desktop, which has a Realtek GBE card, is experiencing very slow upload speeds, averaging 7-10 mbps. Download speeds average about 54 mbps which is fine. Previously when connected to the Fios Actiontec router, speeds were fine in both directions. The wifi was the issue which is why i got a new router.

Steps Taken to Troubleshoot Issue, none of which resolved the issue:

- Replaced ethernet cable with new CAT5e cable
- Unplugged all other devices except desktop, and tried a different port
- Verizon remotely rebooted the main hub in the garage and had me restart the router and computer
- Another laptop gets close to 50/50 using an ethernet por,t so I know the issue is isolated to my desktop
- I changed the default settings on both the NIC and router to 100 full duplex and 1gig full duplex. Neither made an appreciable difference.
- Updated NIC drivers to the latest release.

I asked the Verizon tech if he knew of any settings on either the router or in windows that might help but he didn't want to go that route. Instead he wanted to hard reset the router or send me a new one.  The router was new and I didn't think that would solve my issue so I turned down both requests for now.

I've seen other posting that older computers have issues with the MoCa 2.0 chipset. While that's possible, I'm hoping a buried setting will improve the performance.

So, does anyone have experience with these Quantum routers and poor upload speeds?

Thanks!
D. LepManagerAsked:
Who is Participating?
 
PerarduaadastraConnect With a Mentor Commented:
Why not try changing the NIC for an Intel or Broadcom device? More of the Ethernet functionality is done in hardware on these cards, which reduces CPU usage, particularly under heavy load. Both vendors have long and distinguished pedigrees in network interface products, and while Realtek offerings have improved in recent years I still believe that they haven't overtaken these two doyens of the NIC world.
0
 
JohnBusiness Consultant (Owner)Commented:
Often old computers do not have fast throughput for modern Internet speeds. Not much you can do with that.

Find the Advanced NIC properties (right click on the Network Card, Properties, Advanced) and compare in detail the setting with those below.

https://superuser.com/questions/853500/optimal-setting-for-advanced-parameters-for-realtek-pci-e-gbe-family-network-car
0
 
D. LepManagerAuthor Commented:
@John, I will review my NIC settings tonight and adjust accordingly. Any opinion if a USB 3.0 WiFi adapter would make a difference?
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
JohnBusiness Consultant (Owner)Commented:
A vintage desktop very most likely cannot use USB 3, so no, that will not make difference. A USB2 Internet card might if the Realtek is an old design.
0
 
D. LepManagerAuthor Commented:
Sorry, I should have provided some additional info.  I've replaced most of the components in this Dell Dimension over the years including a USB 3.0 card, GPU and 10k RPM Barracuda drive,  The Realtec 1GB NIC is only about 3 years old.
0
 
JohnBusiness Consultant (Owner)Commented:
In that case you can try a USB 3 adapter. A new USB 3 network adapter (good quality) should be fast.
0
 
pgm554Commented:
NEVER set duplex setting to manual on gigE.
Auto only.
As for speed settings ,the IP stacks on XP and below do not work well with high speed WAN routers.
The stack on Vista and above is greatly improved and should be minimum OS level..
So if you're not using at least Vista ,you will be having prob;ems with WAN through put.
0
 
D. LepManagerAuthor Commented:
I had read about the Realtek NICs offloading tasks to the CPU, and now believe that is my problem.  When running a Speedtest, my CPU would max out at 100%, as well as for other sites.  As there are many Intel and Broadcom NICs out there, any recommendations for a PCI model that will handle more of the tasks on-board vs sending them to the CPU. As a reminder, I'm running Windows 10.
0
 
JohnBusiness Consultant (Owner)Commented:
I would see if you can get an Intel NIC for your machine to replace the Realtek NIC.  Intel are top drawer these days.
0
 
pgm554Commented:
I doubt that's the problem.
I have an older Fujitsu laptop with a Realtek gig and it does 250 down and 12 up on Comcast cable modem.
It's either your router or your IP stack.
spees.PNG
rel.PNG
0
 
JohnBusiness Consultant (Owner)Commented:
If it is not any of the things above, maybe some issue with the operating system holding the Realtek card.

Is it just this one single computer?
0
 
D. LepManagerAuthor Commented:
Yes, just a single Desktop. Does anyone think the CPU maxing out at 100% is the issue, or just the browser grabbing as much CPU power as it can?  I've tried Chrome, IE and Edge, they all do the same thing.
0
 
JohnBusiness Consultant (Owner)Commented:
If you do not think the wireless NIC is the issue, maybe consider a Repair Install of the operating system.

What is the Vintage OS?  and Is it a 32-bit OS or 64-bit OS. If old and 32-bit it may be the bus speeds are not up to snuff.
0
 
D. LepManagerAuthor Commented:
Actually it's Windows 10 64 bit. Bus speeds are definitely slow, no argument there. What I find frustrating is that prior to the Fios Quantum Router, the Actiontec router worked just fine via Ethernet. I had to make the change after the wireless stopped working and I was unable to get it working reliably.
0
 
JohnBusiness Consultant (Owner)Commented:
Try doing a Windows 10 Repair Install to clean it up. Keep Everything.

https://www.microsoft.com/en-us/software-download/windows10

Windows 10 is running, so click on the Download button (not Upgrade Button, select Open (Run) but NOT Save. Allow the program to run. Allow drivers to update. Then select Keep Everything.
0
 
pgm554Commented:
So this is wireless and not wired to the system?
0
 
D. LepManagerAuthor Commented:
Definitely wired, I was just explaining why I switched routers.
0
 
PerarduaadastraCommented:
If the CPU usage hits 100% when the NIC is working hard then that is definitely abnormal. As a test, uninstall the Realtek NIC drivers, power down the machine and remove the Realtek card. Power it up again and re-enable the onboard NIC (being a Dell, this is likely to be either an Intel or Broadcom device). Even though it's only 10/100 (I'm assuming from your previous comments) it may well turn in better performance with your router; if it does, you've confirmed that the problem lies with the Realtek card without spending any money up front.
0
 
D. LepManagerAuthor Commented:
A novel approach. I had issues with the on-board NIC a few years back with either Windows 7 or 8, which is why  I bought the Realtek NIC,  I'll give your suggestion a try and let you know if that makes a difference. Thanks
0
 
D. LepManagerAuthor Commented:
So I tried Perarduaadastra suggestion but was unsuccessful getting Win10 to recognize the onboard NIC. Not surprising since it stopped working at least 3 or 4 years ago.

Anyway, I tried different sites and had better results:

speedtest.xfinity.com/  - 58.73 Mbps down, 63.38 Mbps up
www.speakeasy.net/speedtest/ - 57.8 Mbps down, 56.4 Mbps up

When I tried speedtest.net, it was very slow just to load up and had poor upload speeds, the same as last week.  I thought perhaps the issue is with the site itself. so I downloaded AdBlock and guess what. My upload speed increased to 41.37 Mbps on the first try and  57.57 Mbps on the 2nd try.

I do give some weight to the suggestion on buying an Intel or Broadcom NIC, and that will be my next course of action if the performance becomes unacceptable.

Thanks to all who contributed on this thread.
speedtest.jpg
0
 
D. LepManagerAuthor Commented:
Didn't actually try this solution, but minimizing what is offloaded to the CPU will probably help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.