Home wireless computer has no Internet after adding new SonicWall SOHO wireless-n router

2nd home wireless computer is connected to Sonicwall SOHO wireless -n, but has no internet
J.R. SitmanIT DirectorAsked:
Who is Participating?
 
Blue Street TechLast KnightCommented:
The only one that cannot is Linda.  That is the Wireless computer.

I just turned WiFi on for my phone and it connected
This is not what your DHCP leases are telling me. The fact that you have 5 machines on the 172.16.31.0 network means all of those systems are on the WLAN unless you setup a Bridge of some sort: a wireless Bridge between the SonicWALL and a WAP with built-in switchports, or you Bridged the WLAN to another LAN zone, e.g. X3, etc.

It sounds like you have an issue with one machine's DNS setting because someone manually assigned it.

Do me a favor go to the troubled laptop and go to Start > Run > type CMD, press enter.
Type:
ping 8.8.8.8

Open in new window

what are the results?
Then type:
ping google.com

Open in new window

what are the results?

What is the OS of the troubled laptop?

You need to make sure the laptop's NIC does not have a manually assigned IP/DNS. Go to Control Panel > Network and Sharing Center > Change adapter settings, then R-click on the Wireless NIC > Properties > Internet Protocol Version 4 (TCP/IPv4), double-click it and make sure both Obtain an IP address automatically and Obtain DNS server address automatically are selected and click OK > OK.

If they were both NOT selected then go back to Start > Run > type CMD, press enter.
Type:
ipconfig /release

Open in new window

then
ipconfig /flushdns

Open in new window

then
ipconfig /renew

Open in new window


Let me know if you have any questions!
0
 
JohnBusiness Consultant (Owner)Commented:
What did you plug the Sonic Wall into and does that port on the Sonic Wall have Internet? Log into the Sonic Wall GUI to see
0
 
J.R. SitmanIT DirectorAuthor Commented:
It is plugged into our ARRIS router.  X1 wan to the ARRIS, XO lan to a switch.  The switch to my desktop computer.
0
Increase Security & Decrease Risk with NSPM Tools

Analyst firm, Enterprise Management Associates (EMA) reveals significant benefits to enterprises when using Network Security Policy Management (NSPM) solutions, while organizations without, experienced issues including non standard security policies and failed cloud migrations

 
JohnBusiness Consultant (Owner)Commented:
You have used a WAN port so make sure you plugged the router into a LAN port on the Arris and you have the WAN port on the router set to get a LAN IP from the Arris local subnet
0
 
JohnBusiness Consultant (Owner)Commented:
Just to be very clear, you likely one have one External IP which is on the Arris modem so all other devices will be on the internal subnet
0
 
J.R. SitmanIT DirectorAuthor Commented:
The  ARRIS only has one port Ethenet
0
 
JohnBusiness Consultant (Owner)Commented:
Add a regular switch to give you extra internal Ethernet ports
0
 
J.R. SitmanIT DirectorAuthor Commented:
The desktop is IP 192.168.168.65.  The other wireless computer is 172.16.31.76
0
 
J.R. SitmanIT DirectorAuthor Commented:
The ARRIS is plugged into an 8 port switch
0
 
JohnBusiness Consultant (Owner)Commented:
You have gotten stuff on two subnets so make sure both route to the Arris
0
 
JohnBusiness Consultant (Owner)Commented:
Make sure the switch is on the output side of the Arris modem
0
 
J.R. SitmanIT DirectorAuthor Commented:
So manually change the wireless IP, subnet and DNS on the wireless computer?
0
 
JohnBusiness Consultant (Owner)Commented:
I would do that on the Sonic Wall otherwise you will manually have to configure every wireless device
0
 
J.R. SitmanIT DirectorAuthor Commented:
I am not that knowledgeable on where to make SonicWall changes.  Can you help, with detailed instructions?   I am going to get lunch, back in a bit.
0
 
JohnBusiness Consultant (Owner)Commented:
You need to look at LAN setup area and set up IP and DNS in there
0
 
J.R. SitmanIT DirectorAuthor Commented:
I don't know how
0
 
Jon JaquesInformation TechnologistCommented:
It sounds like you have the order of devices wrong. It should go like this:

Arris Modem Lan -> SonicWall WAN

Then

SonicWall LAN -> Hub/Switch

Then plug all of your other devices into the hub/switch. If set to DHCP, all devices plugged into the switch should now pick up an IP address from the SonicWall.

Make sure that no cables accidentally perform a "loop". If you do accidentally loop and make things not work, power everything off after fixing the problem, and then bring it back up to clear the error condition.
0
 
Blue Street TechLast KnightCommented:
Hi J.R. Sitman,

Having two separate subnets is correct and is exactly how the WLAN and LAN should be setup for a multitude of reasons.

Also. you don't need a switch unless you have more devices than switchports in the SonicWALL.

If your problem is not getting Internet verify that you access the internet from the LAN computers. Please advise so we can proceed.

IF you have access to the Internet via the LAN then and only then you can look at these potential issues for not gaining wireless access to the Internet:
0
 
JohnBusiness Consultant (Owner)Commented:
I would have to study the Sonic Wall docs, so I suggest you now have to do.
0
 
David Johnson, CD, MVPOwnerCommented:
The desktop is IP 192.168.168.65.  The other wireless computer is 172.16.31.76 The gateway should be the same for both desktop/wireless i.e. 192.168.0.1
0
 
JohnBusiness Consultant (Owner)Commented:
Two separate subnets can work but then the computers won't be easily able to talk to each other so I always use one subnet
0
 
Blue Street TechLast KnightCommented:
The WLAN and LAN are on two separate subnets on separate physical & virtual Interfaces so the Gateways cannot be shared (without Bridging them). Therefore, the LAN & WLAN Gateways are unique and are whatever was setup in the Interfaces page, presumably LAN = 192.168.168.1 and WLAN = 172.16.31.1

The OPs question is about specifically connecting to the Internet not cross communication. Residential users don't understand networking which is one of the reasons why ID theft and hacking is soaring. IoT brings virtually no security...then put that on a flat network and it equals easy access all day long!
0
 
JohnBusiness Consultant (Owner)Commented:
True. But you can set it up on the same subnet if you wish so it depends on what is wanted in this situation
0
 
Blue Street TechLast KnightCommented:
The only way to achieve this with WLAN and LAN in separate subnets is to Bridge the Interfaces, which again defeats the security architecture as I mentioned above.
0
 
J.R. SitmanIT DirectorAuthor Commented:
I don't need the computers to communicate with each other I just need one to get internet and it also needs to share a printer. however the printer is not critical
0
 
JohnBusiness Consultant (Owner)Commented:
To share a printer to these two computers, you need (for ease of use/setting up) you need one subnet. It is just vastly easier
0
 
J.R. SitmanIT DirectorAuthor Commented:
I spent the extra money on the SonicWALL so I would not have any security risks.
Might be better if I just call sonic wall on Monday. Since it's brand new and has maintenance
0
 
JohnBusiness Consultant (Owner)Commented:
Yes. I agree with you. They will tell you how to achieve one subnet which facilitates printing
0
 
Blue Street TechLast KnightCommented:
Security is not a product! You bought a device that has the capabilities of increasing your security...achieving it is accomplished through know-how and configuration. Nothing in security is plug-n-play....its all about how you design it and configure it!

Communicating between two networks is done all day long...it's not a big deal. In fact accessing the Internet is communicating between two or more networks.

I'd advise against bridging the networks (WLAN and LAN) for stronger security. IoT + flat network = easy penetration!

All you have do is allow either the printer's IP or the port on the WLAN>LAN and LAN>WLAN Access Rules. This is jumping the gun though if you can't even connect to the Internet...that was your question so let's solve that first and foremost.
0
 
JohnBusiness Consultant (Owner)Commented:
For 2 devices, life is just easier with one subnet and decent security can be achieved with firewall and other rules. Just a different way to do things
0
 
J.R. SitmanIT DirectorAuthor Commented:
So can one of you give me "detailed" step-by-step instructions to solve the internet issue?
0
 
Blue Street TechLast KnightCommented:
Yes! You need to provide answers for each question...step-by-step.

1. The Wireless Radio is disable by default so verify you have it enabled!
2. Verify SonicWALL DNS is configured properly - test in System Diagnostics > Diagnostic Tool: Check Network Settings - Test all.
3. Verify DHCP is enabled for the WLAN (W0 Interface).
4. Make sure your wireless device has the most current driver - update this with the manufacturer.

This is to start then we will proceed once this section is cleared.
0
 
J.R. SitmanIT DirectorAuthor Commented:
Wireless radio is enable.  The printer on the wireless computer works.
All tests passed.
Not sure where to
sonicwall2.jpg
0
 
J.R. SitmanIT DirectorAuthor Commented:
Sorry, hit submit.   I am not sure where to check DHCP
0
 
Blue Street TechLast KnightCommented:
Network > DHCP Server
0
 
JohnBusiness Consultant (Owner)Commented:
Another thing you (Author) can do is replace your main router with the Sonic Wall and just you it. It should have Ethernet ports as well as wireless.  Use a small switch if you need more Ethernet ports. Look for simplicity.
0
 
Blue Street TechLast KnightCommented:
I noticed you posted you posted your Access Rule, incidentally, modify your WAN>LAN to DISCARD IMMEDIATELY!!!!, disable HTTP login (and HTTPS unless you have a really good need to remotely access the firewall), and disable ping from the WAN. Do both in Interfaces then click on X1 to configure it.

If you need remote access to manage the firewall the secure way to do this is via SSL-VPN management by setting up SSL-VPN w/2FA.
0
 
Blue Street TechLast KnightCommented:
modify your WAN>LAN to DISCARD IMMEDIATELY!!!! You have sabotaged your security...might as well be directly connected to the Internet!
0
 
JohnBusiness Consultant (Owner)Commented:
Consider just using one router and avoiding complexity. Something you can service by yourself down the road.
0
 
J.R. SitmanIT DirectorAuthor Commented:
Discard "where"

discard
0
 
Blue Street TechLast KnightCommented:
Action: Discard
0
 
J.R. SitmanIT DirectorAuthor Commented:
done
0
 
Blue Street TechLast KnightCommented:
where are you at with the DHCP server?
0
 
J.R. SitmanIT DirectorAuthor Commented:
yes, enabled.

dhcp
0
 
J.R. SitmanIT DirectorAuthor Commented:
did you see my post?
0
 
Blue Street TechLast KnightCommented:
It looks like your DHCP server is enabled and working (providing leases). There is a column over to the right labeled Enable. Each row represents either a DHCP Scope or an individual Static Assignment. Are both Scopes enabled?

There are 5 WLAN devices that were handed out leases so it was working at one point. Are any of these devices able to access the Internet?
0
 
J.R. SitmanIT DirectorAuthor Commented:
The only one that cannot is Linda.  That is the Wireless computer.

I just turned WiFi on for my phone and it connected
0
 
J.R. SitmanIT DirectorAuthor Commented:
I ran a diagnostics on the computer and it states it cannot communicate with the primary DNS server.  In Ipconfig they are 70.10.216.1 and .2
0
 
JohnBusiness Consultant (Owner)Commented:
Set DNS in the Sonic Wall and do a TCP/IP reset on the Workstation
0
 
J.R. SitmanIT DirectorAuthor Commented:
@John.  You do not understand, I need "detailed" steps.  Please.
0
 
JohnBusiness Consultant (Owner)Commented:
I am away until later. Google for TCP/IP reset and do that to fix the Workstation
0
 
JohnBusiness Consultant (Owner)Commented:
Hello JR:

TCP/IP Reset, DNS Flush

Open cmd.exe with Run as Administrator
Then: netsh int ip reset c:\resetlog.txt
Then: ipconfig /flushdns
Then: restart the computer

Sonic Wall Settings for IP, Gateway and DNS

https://www.sonicwall.com/en-us/support/knowledge-base/170503515063397

Best of luck
0
 
J.R. SitmanIT DirectorAuthor Commented:
@ Blue Street Tech.   Thanks.   The NIC had a static IP.  Everything is working.
0
 
J.R. SitmanIT DirectorAuthor Commented:
Thanks to everyone for all the advice and help.
0
 
JohnBusiness Consultant (Owner)Commented:
The NIC had a static IP.  Everything is working.

That is why I asked you to do a TCP/IP reset (with instructions) . That will fix the issue.
0
 
Blue Street TechLast KnightCommented:
Glad I could help and thanks for the points!
0
 
J.R. SitmanIT DirectorAuthor Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.