Windows 10 Computer goes to sleep

Power Options1Power Options2Hi,
 I have a domain-joined HP computer running Windows 10 Pro.
 This computer went to sleep on this past Saturday. This is second time going to sleep. First time when it happened was when I set up this new computer first time and the default settings took over, so it I went to Power Settings in Control Panel and did the following:
1. Set  "Turn off hard disk after" to 0.
2.  Set "Sleep after" to "Never".
3.  Set  "Allow Hybrid Sleep" to "Off".
4. Set "Hibernate after" to "Never".
 
 Since then it has been fine since then.
 But It went to sleep again around 11:20AM Saturday.
 When I checked Event Viewer, I see the following in SYSTEM log.
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
4/21/2018 11:19:47 AM  Event ID: 1074
The process C:\Windows\System32\RuntimeBroker.exe (RON) has initiated the power off of computer RON on behalf of user PDISANECK\RTaylor for the following reason: Other (Unplanned)
 Reason Code: 0x0
 Shutdown Type: power off

4/21/2018 11:19:52 AM  7002
User Logoff Notification for Customer Experience Improvement Program

4/21/2018 11:19:53 AM  26
Application popup: SRFeature.exe - Application Error : The application was unable to start correctly (0xc0000142). Click OK to close the application.

4/21/2018 11:19:55 AM  1
The system time has changed to ‎2018‎-‎04‎-‎21T15:19:55.690994900Z from ‎2018‎-‎04‎-‎21T15:19:55.691019600Z.
Change Reason: An application or system component changed the time.

4/21/2018 11:19:56 AM 42
The system is entering sleep.
Sleep Reason: Application API
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Is there anything else that could cause this computer to go to sleep?
The strange thing is that it has not gone to sleep for SEVERAL WEEKS (since last sleep) and I have not changed anything on this computer.
Fyi, there is no Domain/Group Policy that forces any computer to go to sleep.

Can you help?
LVL 1
sgleeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dr. KlahnPrincipal Software EngineerCommented:
4/21/2018 11:19:52 AM  7002
User Logoff Notification for Customer Experience Improvement Program


<flame>
Well, I personally would start by disabling CEIP, as Microsoft has no legitimate business knowing what you are doing on your own computer.
</flame>

Then I would disable sleep and forcibly disable hibernation using the instructions at the page below:

https://www.pugetsystems.com/labs/support-software/How-to-disable-Sleep-Mode-or-Hibernation-793/

And then run it for a few days and see if the problem recurs.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
I would reinstall / update the Power management driver.

Before doing this (2018 now), update BIOS, Chipset, and Video. Then Update the PM driver and restart.
0
sgleeAuthor Commented:
@Dr. Klahn
I read an article and basically it talks about the steps that I have already taken per my screenshots.
"powercfg.exe /h off"  may be the only new here?

@John
"I would reinstall / update the Power management driver." --> how do you do that?
Has this happen to you before?
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

JohnBusiness Consultant (Owner)Commented:
I have not had this issue on Lenovo machines. Still, go to the HP Support site for your machine here and find the Power Management Driver. Download it and run it to install.

Powercfg is a command way to do the GUI power settings
0
Dr. KlahnPrincipal Software EngineerCommented:
"powercfg.exe /h off" is the only sure way to disable hibernation.  And as a nice side effect it destroys the hibernation file, which will save you disk space equal to the amount of memory installed in the system.
0
sgleeAuthor Commented:
@John @Dr. Klahn
I will try your suggestions later in the evening.
0
JohnBusiness Consultant (Owner)Commented:
I went back to your screen shot of power management. It has an icon for settings not available unless Admin.

Are you running Power Management under an Admin Profile?
0
sgleeAuthor Commented:
@John
"Are you running Power Management under an Admin Profile? " --> I noticed that too for the first time. I usually assign "local administrator" privilege on each network user. So the user is a local admin.
But I don't see "Change settings that are currently unavailable" on my computer. For example, I am network admin.
Let me check some other network PCs ...
0
JohnBusiness Consultant (Owner)Commented:
Something is amiss.  Consider a Windows 10 Repair Install and Keep Everything.

https://www.microsoft.com/en-us/software-download/windows10

Windows 10 is running, so click on the Download button (not Upgrade Button, select Open (Run) but NOT Save. Allow the program to run. Allow drivers to update. Then select Keep Everything.
0
sgleeAuthor Commented:
@John,

  I checked three different PCs on the same network and they all show that message and they don't go to sleep.
0
JohnBusiness Consultant (Owner)Commented:
You may have a GPO policy causing this.

Even so, for the one computer, consider the repair install.
0
sgleeAuthor Commented:
Let me try "powercfg.exe /h off" first.
If it happens again, then I will do "repair install".
"You may have a GPO policy causing this." --> if that is the case, then shouldn't this happening to all domain joined computers on the network?
0
JohnBusiness Consultant (Owner)Commented:
I just checked a domain connected computer here and no Admin Shield icon.

I am not sure what this would be other than the particular way the GPO affects it.
0
sgleeAuthor Commented:
"other than the particular way the GPO affects it. "--> good question. I am not familiar with GPO, so I don't create a GPO. I might have created something way back for something else ... I don't remember. but certainly have not done anything to GPO. Again this problem is happening to this new HP PC.
0
JohnBusiness Consultant (Owner)Commented:
Also remember back here that you need also to update BIOS and Chipset
0
sgleeAuthor Commented:
"update BIOS and Chipset " --> will do.
0
nobusCommented:
i never set my disk to turn off after 0 minutes - imo this means it is Always off
i set it to never, or at least 1 hour
0
sgleeAuthor Commented:
@nobus
"imo this means it is Always off " --> thanks for pointing that out. I will change it to NEVER.
0
nobusCommented:
let me know how it goes
0
sgleeAuthor Commented:
@nobus
"set my disk to turn off after 0 minute" --> this would not put the computer in hibernation, right?
0
nobusCommented:
i thought it was clear what it did - you turn your disk off - nothing else but i don't know what effect it has on your system - i guess without disk it won't do much
you can test  it on another system !
0
sgleeAuthor Commented:
I have not made any changes to the computer yet and the computer has NOT been turned off since Saturday.
I am going to keep it the way at least until next time.
I hesitate to make any changes because:
(1) it has been working fine except "one-time shutdown by itself" once.
(2) if this problem happened because of some kind of power settings, it should have been happening more often, but it hasn't.

Thanks you all for your suggestions and they were good to know.
I am closing the case.
0
JohnBusiness Consultant (Owner)Commented:
Thanks for the update
0
nobusCommented:
>>   the computer has NOT been turned off since Saturday.  <<  it's your call, but my pc's are turned off 3x per day at least
the startup is so fast it does not hinder, and it resets your softwares
i'm sorry you did not appreciate my help...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.