Windows 7 machine refuses to accept static IP

Windows 7 machine refuses to accept static IP from Firewall - I have a Windows 7 machine I'm trying to setup with a static IP. The current IP it grabs automatically is 192.168.1.221, which is a dynamic address. I'm trying to make it 192.168.1.98 on the Sonicwall firewall. I've setup every other machine in the office in this manner (Using the MAC address and assigning the IP address) with no problems. .98 is the next available address. It refuses to take it. When I reset the configuration it gives me an "Unidentified/no internet" yellow error and comes up with a 169.254.57.251. If I disable the entry on the Sonicwall it comes back up with the .221 dynamic address.

I've checked every other place I can think of. I've checked to make sure the IPv4 address is set to obtain automatically. I've tried forcing the .98 address through the PC by entering it manually instead of pulling it from the Sonicwall. I've even tried changing the static lease to a different number (.99) with the same results. It only seems happy with that .221 address.

To recap:

PC will only pick up a dynamic IP
Tried to give it a static IP on the firewall and it comes back with a bad IP
Tried to give it a static IP on the computer itself and I have the same problem
I've disabled IPv6
I've triple checked there are no other machines with the .98 address

Any help would be greatly appreciated
TarkisalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ChrisCommented:
More than likely 192.168.1.98 is already in use by a device on the network.

On the sonicwall, check the ARP table to see if it's learned a MAC address for that IP. If it has, then an IP conflict is the cause of the issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TarkisalAuthor Commented:
This was absolutely right. I found the .98 in the ARP table on the SonicWALL attributed to a device with a different MAC and a label of "Unknown." Changing .98 to .100, which was not in the ARP table, fixed the problem. Thank you for the quick and helpful response!
0
ChrisCommented:
Glad to help.

As an aside, it might be worth trying to figure out what the rogue device is. A useful tool to assist with this is https://macvendors.com/ or https://www.macvendorlookup.com/.

Chuck the MAC into one of those sites and they'll tell you the manufacturer of the network adaptor of the unknown device. Might give you some idea what the device is.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.