vPC question with regards to VMWare hosts

Hey Everyone,

Need some input from Cisco gurus. I'm planning on deploying a pair of Nexus 3524x switches for our server environment. I'm going to configure vPC between both pairs of switches, but I'm wondering about the server side of things. We are going to implement ESXi hosts and a Netapp SAN, and I'm wondering if I need to configure vPCs to the new servers and Netapp or would a standard port-channel with LACP work?
Richard BrodeanSystem AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

atlas_shudderedSr. Network EngineerCommented:
This is one of those subjects that sounds a lot more complicated than it really is, don't sweat it.

Configure your peer link between the 3524's.
ex -
interface Ethernet1/53
  description Peer Link
  switchport mode trunk
  switchport trunk native vlan 200
  channel-group 200 mode active
  no shutdown

interface Ethernet1/54
  description Peer Link
  switchport mode trunk
  switchport trunk native vlan 200
  channel-group 200 mode active
  no shutdown

interface port-channel200
  description VPC Trunk to XXX
  switchport mode trunk
  switchport trunk native vlan 200
  spanning-tree port type network
  vpc peer-link

Open in new window


On each switch, configure your port-channel(s) as you normally would with the exception of the adding the vpc assignment:

interface Ethernet1/1
  description Server X
  switchport access vlan 210
  switchport trunk allowed vlan 1,210
  spanning-tree port type edge
  channel-group 701 mode active
  no shutdown


interface port-channel701
  description Server X
  switchport access vlan 210
  switchport trunk allowed vlan 1,210
  spanning-tree port type edge trunk
  vpc 701

Open in new window


Bingo bango - Bob's your uncle.  Best practice is to identify the VPC same numerically as your port channel.

You can check the vpc status after hosts are connected using:

Switch# show vpc brief
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 9   
Peer status                       : peer adjacency formed ok      
vPC keep-alive status             : peer is alive                 
Configuration consistency status  : success 
Per-vlan consistency status       : success                       
Type-2 consistency status         : success 
vPC role                          : primary                       
Number of vPCs configured         : 14  
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Enabled
Auto-recovery status              : Disabled
Delay-restore status              : Timer is off.(timeout = 30s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans    
--   ----   ------ --------------------------------------------------
1    Po200  up     1,99,200,210,212-213                                   

vPC status
----------------------------------------------------------------------
id   Port   Status Consistency Reason                     Active vlans
--   ----   ------ ----------- ------                     ------------
701  Po701  up     success     success                    210             
                                                                          
702  Po702  up     success     success                    210             
                                                                          
703  Po703  up     success     success                    210             
                                                                          
704  Po704  down*  success     success                    -               
                                                                          
705  Po705  up     success     success                    210             
                                                                          
706  Po706  up     success     success                    210             
                                                                          
707  Po707  up     success     success                    210             
                                                                          
708  Po708  up     success     success                    210             
                                                                          
709  Po709  up     success     success                    210             
                                                                          
710  Po710  up     success     success                    210             
                                                                          
711  Po711  up     success     success                    210             
                                                                          
712  Po712  up     success     success                    210             
                                                                          
713  Po713  up     success     success                    210             
                                                                          
715  Po715  up     success     success                    210 

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Richard BrodeanSystem AdministratorAuthor Commented:
Ah great, thank you sir, much appreciated!
0
Richard BrodeanSystem AdministratorAuthor Commented:
Thanks!
0
atlas_shudderedSr. Network EngineerCommented:
No worries.  It's fairly simple once you get your head wrapped around the fact that it's kind of a VSS lite.  Good luck.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.