Joomla articles cut off after 28 words.

I'm running Joomla 3.8.7 When I make a category the default home page all the articles cut off like there was a "read more" character in the article with the exception that there is no "read more" button. I cannot figure out what I have done to cause this behavior. I've tested my process on another 3.8.7 site and things behave as expected so it's got to be something I'm doing on the current site. I'd be happy to use the new site except there is so much content to transfer. Any suggestions would be gratefully accepted. The site is dataqualitynetwork.net
tiusupportAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Steve BinkCommented:
When you say "I make a category the default home page", how exactly are you doing that?
0
Peter HartCommented:
have you tried using a different theme?
0
tiusupportAuthor Commented:
When you say "I make a category the default home page", how exactly are you doing that?

- I should have said "marked as featured". I display "featured articles" on the home page

have you tried using a different theme?

- yes
0
Steve BinkCommented:
First, have a look at the HTML source.  Do you see the full article text in the source, or do you see the 28-character limited version?

If you see the full text, then your issue is somewhere in the CSS for the theme.  You'll have to investigate and address it there.  If you only see the limited version in source, then it is likely that your config is limiting the content.  The config can be in three places: global config, menu config, article config.  These setting cascade in unintuitive ways, so you may need to do some testing to figure out what is being applied where.

The global config is found in [System | Global Configuration] from Joomla's admin menu bar, then click on "Articles" in the section list.  Verify the settings under each of the tabs, paying special attention to "Articles" and "Blog/Featured Layouts".  As suggested by their location, these are global configuration items for the entire site.  They will be applied as a default configuration, and can be overridden by the other two areas.

The menu config is found on the "Layout" and "Options" tabs of the menu item.  Most of these are likely set to honor the global configuration.  Verify all the settings here (refer to the global config, if necessary).

Finally, the article config is found on the "Options" tab of each article.  Again, these are usually carrying the global defaults.  In the context of a menu item being rendered, I *believe* the menu item's config takes precedence over the article's, but I would verify the settings to make sure.

If you have audited all the config points and are still encountering this issue, try temporarily disabling any third-party plugins of type "content".
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Content Management

From novice to tech pro — start learning today.