Error Reading File... (Windows 10 / Windows Server 2012 R2)

I have a Domain (Windows 2012 R2) with 10 Stations.

I have 1 station with some problems when accessing an application (Visual Foxpro 9).
when the application is active but idle for few minutes we get an error "Error reading file....".
We shutdown the application and restart it, it works fine for another few minutes... and again ,if the PC is idle for few minutes, it gives the same error.

I tried changing the NIC, removing the Power management from everywhere on the PC (NIC, HDD, etc... ) it did not change anything...

The weird thing is that If I have an excel file open from the same share folder, it doesn't give any error..

Any help ?
Pierre AmmounAsked:
Who is Participating?
 
pcelbaCommented:
Did you check Registry entry
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters Value: KeepConn
as proposed in the link from my first post?

What is the value?
0
 
pcelbaCommented:
Does this happen when the application does not stay idle?
Do you use drive letters or share names?

You may try following (on the workstation):

net config server /autodisconnect:-1

net use x: \\<servername>\<sharename> /persistent:yes

Also please read hints in this KB article: https://support.microsoft.com/cs-cz/help/297684/mapped-drive-connection-to-network-share-may-be-lost
0
 
Wayne88Commented:
Can you try disabling SMB2 for testing purposes? It's known to cause VFP issues.  If that is the problem then try creating firewall application exception rule but let's try to narrow it down first.

https://support.microsoft.com/en-ca/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Pierre AmmounAuthor Commented:
I tried to disable Smb2 as suggested ...
same problem.
as for share persistent this is already the case...
same problem...
what is weird is that I have other users on the system (same app) with no issues... Though not Windows 10 !
0
 
pcelbaCommented:
So you are using drive letter with persistent share definition on Windows 10.  What about the autodisconnect?
Disconnecting should appear in Windows logs. Did you check them?

Does the drive letter disappear from Windows Explorer when this error appears?
Does the problem occur when the VFP 9 app is idle but Excel has open some file on the same share?

Are you able to use UNC instead of drive letter? Does it behave the same way?

If this behavior is observed on Windows 10 only and no hint works for you then you have two options:

Create the "Keep Alive" timer in your app. This timer should fire every 30 or 60 secs and do the following:

USE some file on the share
REPLACE one row with something
Close the file.

It should help based on what you were saying till now.
0
 
Pierre AmmounAuthor Commented:
Dear LVL44,

I tried to keep a command prompt open with a "ping -t" to the server... and it did not help !

What is "Keep alive" timer ?
0
 
Wayne88Commented:
"I tried to disable Smb2 as suggested ..."

Sorry, just realized it's Windows 10.  You said the others are not having issues running the same app and they are not on W10.  W10 by default blocks lower SMB protocol.  After disabling SMB2 did you enable SMB1?

Will it be possible to test if this is the case to narrow down the problem?  

https://support.wdc.com/knowledgebase/answer.aspx?ID=20736
0
 
pcelbaCommented:
The ping cannot help to keep the shared folder connected. It just ensures the server is running but nothing else.

The "Keep Alive" timer is a VFP 9 code which implements the timer object. This object then simulates data access even when the application is inactive.

If you are not the VFP 9 application code owner then you may write another (very small) VFP 9 app which will implement this timer.

BTW, LVL44 is not my name just rank assigned by EE.  The name is introduced by "by:"  in message heading. :-)
0
 
pcelbaCommented:
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.