Pointing Outlook at Office 365 instead of SBS 2008

I have migrated the SBS 2008 mailboxes to Office 365. The problem lies somewhere in Outlook. I can manually configure Outlook on the workstations to point to Office 365 but as soon as I reboot the workstation  Outlook reverts to pointing to their Exchange Server. They are a mix of Outlook 2010 and Outlook 2011. Isn't there any way to turn off autodiscover on Outlook?
LVL 15
LockDown32OwnerAsked:
Who is Participating?
 
LockDown32Connect With a Mentor OwnerAuthor Commented:
Reconfiguring Autodiscover seems to be the key but no one has said how to do that.....
0
 
Vasil Michev (MVP)Commented:
Did you change the autodiscover record to point to O365? Both internally and externally? While manual configuration can work, Outlook uses autodiscover for more than just configuring the profile, so disabling it is not an option. One thing you can do is to "instruct" Outlook to only look for the CNAME entry (HTTP Redirect), as detailed in this article: http://support.microsoft.com/kb/2212902

You can block all other methods, the CNAME entry is the only one you need for Office 365.
0
 
LockDown32OwnerAuthor Commented:
Vasil there wasn't a lot of detail in that article with respect to just the HTTP Redirect. Do you have suggested registry setting that will accomplish what I need to accomplish?

I have no idea where the internal autodiscover record is nor how to change it to point to Office 365. I am assuming the autodiscover record at autodiscover.outlook.com would be correct????
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
Vasil Michev (MVP)Commented:
All the reg keys you need are in the article, for your scenario setting the ExcludeHttpsRootDomain and ExcludeHttpsAutoDiscoverDomain should be enough. If you need more detailed explanation on what each setting does, read here: https://support.microsoft.com/en-us/help/3211279/outlook-2016-implementation-of-autodiscover
0
 
LockDown32OwnerAuthor Commented:
Well.... those two registry entries are set to "1" and it doesn't do anything different. When I open Outlook I keep getting the pop-up about "Allow this website to configure server settings". Checking the box to not ask again does't work. It continually keeps popping up. I am going to assume that the user hitting "allow" it what it changing the settings back to the exchange server.

   The web site is https://autodiscover-s.outlook.com/autodiscover/autodiscover.xml I have a feeling that is the internal autodiscover record and that the only way to get this working is going to be to edit that autodiscover record to point to Office 365. You mentioned it above but never mentioned how to edit it......
0
 
Vasil Michev (MVP)Commented:
Simply point it to autodiscover.outlook.com.
0
 
LockDown32OwnerAuthor Commented:
Mich simpler said than done. Exactly how do you do that?
0
 
LockDown32OwnerAuthor Commented:
No solutions given
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.