SMTP failing for program on application server

I'm having an issue getting SMTP (outgoing) communication to work for a program on an application server.

I need help from an expert to identify what SMTP settings i would need to apply for my situation. I currently have it set as SMTP port 25 no TLS, no authentication required. Ive tried many combinations of those settings as well. All have failed.

I can access any of the servers we need to piece this together and also have access to Exchange in all regards.

The program in question is Manage Engine Service Desk and we have an on-premise Exchange 2013 CU 19 environment. The server the program resides on is Windows Server 2012 R2.

I'm curious about powershell commands that reveal the current SMTP settings and can maybe test connectivity from the application server to exchange itself, things like that. Im really stumped on why this doesn't work. I think it should be easy. Than again when we say Exchange i envision a large mountain. :)

Thank you for any help on this
Tom MonroeLocal IdiotAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
Have you configured a special connector on the Exchange server to allow relaying from the server where the application runs?  I've read some articles that say you don't have to do that, but I've never been able to make it work without a special connector to allow relaying from the internal application server through the Exchange server. Here's how I have mine set up:

Authentication: TLS (not mutual); Externally secured
Permission groups: Exchange servers, Legacy Exchange servers, Exchange users, Anonymous users
Scoping: specific IP address(es) of internal server(s) or other devices that need to send email through this connector
Adapter bindings: port 25
0
AmitIT ArchitectCommented:
In your case, you need to configure anonymous relay connector. Then add server ip, from which you are trying to send mail into that connector. For more info:
https://technet.microsoft.com/en-us/library/bb232021(v=exchg.141).aspx
0
Tom MonroeLocal IdiotAuthor Commented:
Okay great this makes a lot of sense. let me attempt to build this on the CAS servers and then see how it goes. Really appreciate the help so far!!
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Tom MonroeLocal IdiotAuthor Commented:
okay on Scoping for Remote network settings i have the entire range in there, 0 - 255.255.255.255, for the network adapter binding i have the application servers IP and port 25, is that correct?
0
AmitIT ArchitectCommented:
You can remove it. For more info you can check this one.
https://www.petenetlive.com/KB/Article/0000542

Once you are done, run this command:
    Get-ReceiveConnector "Receive Connector Name" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Tom MonroeLocal IdiotAuthor Commented:
Hi AMit,

I'm following your walk through and im getting this error below when i attempt to run this powershell command on the CAS servers.

In our environment the CAS servers are separate from the mailbox servers.

Should i build this on the Mailbox servers as well as the CAS Servers?



Get-ReceiveConnector -Identity “ServiceDeskSMTP” | Set-ReceiveConnector -TarpitInterval 00:00:00 -ConnectionTimeout 00:30:00 -ConnectionInactivityTimeout 00:20:00 -MaxAcknowledgementDelay 00:00:00 -MaxInboundConnection 10000 -MaxInboundConnectionPercentagePerSource 100 -MaxInboundConnectionPerSource unlimited

Fails with : The operation couldn't be performed because object "mailbox2.domain.com" couldn't be found on "dc.domain.com"
0
AmitIT ArchitectCommented:
Looks like AD replication is pending. Wait for sometime after creating the connector. Then you try again.
0
Tom MonroeLocal IdiotAuthor Commented:
Still no luck on those commands. I swear my exchange system is always an uphill battle. Any other ideas?
0
AmitIT ArchitectCommented:
Try this:
Run this first:
Get-ReceiveConnector
You will see the proper name under identity. Copy and paste in your command. Like:

Get-ReceiveConnector -Identity “Servername\ServiceDeskSMTP” | Set-ReceiveConnector -TarpitInterval 00:00:00 -ConnectionTimeout 00:30:00 -ConnectionInactivityTimeout 00:20:00 -MaxAcknowledgementDelay 00:00:00 -MaxInboundConnection 10000 -MaxInboundConnectionPercentagePerSource 100 -MaxInboundConnectionPerSource unlimited

Let me know, if still error.
0
Tom MonroeLocal IdiotAuthor Commented:
okay adding in the servername allowed to enter all of those commands, Thank you!

Should i do anything further or give it a test?
0
AmitIT ArchitectCommented:
I assume you ran this command:
Get-ReceiveConnector "Receive Connector Name" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

If not run it and then you test it.
0
Tom MonroeLocal IdiotAuthor Commented:
Do these settings look correct based off of how we setup the receiver?
Capture33.PNG
0
Tom MonroeLocal IdiotAuthor Commented:
Yes i ran your original command, it completed successfully when i ran it. okay testing now
0
AmitIT ArchitectCommented:
I assume you added your server ip, into new relay connector. Yes setting looks fine.
0
Tom MonroeLocal IdiotAuthor Commented:
here is how the connectors are configured does this look right as well?
Capture55.PNG
0
AmitIT ArchitectCommented:
Yes, looks fine, you can goahed and test. let me know, if any error.
0
Tom MonroeLocal IdiotAuthor Commented:
OKay AMIT you did it my friend!! You are a true gem in the IT world. !!
0
Tom MonroeLocal IdiotAuthor Commented:
I would like to thank all of you for helping. Amit you are simply wonderful, I thank you to the moon and back. Please have a fantastic day!
0
AmitIT ArchitectCommented:
Glad to help :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.