RHEL 7.4 - cant get network working

Dell PowerEdge R630.
Installed RHEL7.4 on a physical server (not VMware).

I configured the network-config to use the old naming convention by placing "net.ifnames=0 biosdevname=0" at the end of GRUB_CMDLINE_LINUX in the /etc/default/grub file.

Then I ran:

grub2-mkconfig -o /boot/grub2/grub.cfg
cd /etc/sysconfig/network-scripts
mv ifcfg-em3 ifcfg-eth3

Open in new window


In this server, ports 2 and 3 are connected so I am working with port3.

Then I disabled the Network Manager because I found posts online saying this could cause issues.

systemctl stop NetworkManager
systemctl disable NetworkManager

Open in new window


When I reboot the server - I do see the eth3 connection up when i do 'ifconfig' but I have no connectivity at all. No pings works except pinging the local IP.

I checked the HWADDR in the ifcfg-eth3 files matched the actual MAC address by appending that file

cat /sys/class/net/eth3/address >> ifcfg-eth3

Open in new window


and then setting that address as 'HWADDR'

when i try starting the network.service I get this error:

Error1.JPG

Any idea what I am missing here? This is config of ifcfg-eth3:


eth3.JPG





EDIT: I noticed I had an 'ifcfg-eth1' file with no config inside. I wrote in ONBOOT=NO and BOOTPROTO=none. Rebooted the server and now the network.service is active but still do not have any connectivity.
There are still multiple messages stating 'RTNETLINK answers: File exists.
SeeDkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SeeDkAuthor Commented:
WOW. I got it working and it was such a stupid problem.
Issue was: the physically connected ports on the NIC are 3 and 4 as I stated. (Not sure why its like this).

BUT in RHEL, the port MAC addresses are mapped to eth0 and eth1. I double checked this by checking what the MAC addresses for ports 3 and 4 were listed as on the iDrac card.

So physical ports 3 and 4 = config eth0 and eth1 in RHEL.
I configured the config to eth0, rebooted and viola! Network connectivity.
This whole thing could have been avoided had the cables been connected to 0 and 1 physically as normally would be the case.

Now I want to set up having these two ports work together for redundancy. Should the setup be similar as it was in RHEL6 or is there anything different?
0
nociSoftware EngineerCommented:
The complaint is about adding routes... (Setting an address also establishes some routes...)
Dupplicate addresses?
what does netstat -rn show?
0
nociSoftware EngineerCommented:
oh that is easy.... if using netbiosnames or hardware based names those are em3 / em4.....
BUT if the kernel renames interfaces, then the FIRST interface seen will be eth0, then next eth1, .... etc.
So it's not RHEL, but the chosen naming options... passed on the kernel commandline
(on y system they gate called enpXsY  where p  a slot on the PCI bus and s a sub index / PCI adapter.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.