iPhone X unable to connect to exchange 2013

Hello,

I have a user who is using an iPhone X and is trying to connect to exchange via the apple mail app but keeps getting the error message "Cannot get mail the connection to the server failed."

I know the information is correct that I am entering to the exchange profile within the phone, I have test on an iPhone 8Plus and had no issue connecting to the mail box on multiple occasions. In the Exchange Admin Center for Exchange 2013 I only see a total of 3 devices under mobile devices, the users iPhone X, My phone and an iPad that is working fine, so I know I am below the ten device max connection.

I have disabled FaceID incase that was causing an issue with the passcode minimum, still unable to login.

The phone is using IOS 11.3.1
Exchange Server is Exchange 2013
RDCitAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
Are you using any MDM product. Like Blackberry UEM? Or is there any policy set, which blocks 11.3.1 IOS.
RDCitAuthor Commented:
We do have a device policy but the only restrictions is a passcode of 6 characters.
AmitIT ArchitectCommented:
Check IIS logs. In that you can find, why it is failing. Just copy latest logs, open in notepad ++.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Kyle SantosQuality AssuranceCommented:
I've put together an article that has crowd sourced solutions others have used to solve their problems.  Check it out.
https://www.experts-exchange.com/articles/19119/Phone-Can't-Connect-to-Exchange-Server.html
RDCitAuthor Commented:
which Log file would it be under?
AmitIT ArchitectCommented:
It will be under inetpub, default path.

C:\inetpub\logs\LogFiles

you need to first trigger the issue again and then get the latest log.
Scott CSenior EngineerCommented:
Just a thought...do a Get-MobileDevice for the user and see how many devices they have assigned.

https://docs.microsoft.com/en-us/powershell/module/exchange/devices/get-mobiledevice?view=exchange-ps

I've seen it before when people like to change devices every couple of months and when they hit 10.  Then BAM!!  That's it.  No more can be added until some are removed.
William FulksSystems Analyst & WebmasterCommented:
Get into your webmail and look at the list of devices under Options - Phone to make sure it really is less than 10. I understand it shows a different list there.
RDCitAuthor Commented:
Fixed it by removing the account. hard rebooting the phone and readding the account.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kyle SantosQuality AssuranceCommented:
Nice.  Did you get that from my article's solutions or just tried that on your own?
Restart the device (and/or server), delete the account or a combination of both.
RDCitAuthor Commented:
Tried that on my own, I turned the phone off and on and tried to reconnect but that did not work.
Kyle SantosQuality AssuranceCommented:
That's great you were able to solve the problem!
SysToolsData Expert - Recovery,Backup,MigrationCommented:
To Connect Apple Device with Exchange Server Visit : https://support.apple.com/en-in/HT201729
RDCitAuthor Commented:
below is the log from the phone, does anyone understand these exceptions?

Command_WorkerThread_Exception :
--- Exception start ---
Exception type: Microsoft.Exchange.Data.Storage.SyncStateExistedException
Exception message: The sync state named 12 already exists.
Exception level: 0
Exception stack trace:    at Microsoft.Exchange.Data.Storage.SyncState.CreateSyncStateFolderInFolder(SyncStateInfo syncStateInfo, Folder syncStateParentFolder, PropertyDefinition[] properties, Object[] values, ISyncLogger syncLogger)
   at Microsoft.Exchange.Data.Storage.SyncState.CreateSyncStateStoreObject(SyncStateStorage syncStateStorage, SyncStateInfo syncStateInfo, Folder syncStateParentFolder, PropertyDefinition[] properties, Object[] values, ISyncLogger syncLogger)
   at Microsoft.Exchange.Data.Storage.FolderSyncState.CreateSyncState(SyncStateStorage syncStateStorage, Folder syncStateParentFolder, ISyncProviderFactory syncProviderFactory, String syncFolderId, ISyncLogger syncLogger)
   at Microsoft.Exchange.Data.Storage.SyncStateStorage.CreateFolderSyncState(ISyncProviderFactory syncProviderFactory, String syncFolderId)
   at Microsoft.Exchange.AirSync.SyncCollection.OpenSyncState(Boolean autoLoadFilterAndSyncKey, SyncStateStorage syncStateStorage)
   at Microsoft.Exchange.AirSync.SyncCommand.SyncTheCollection(SyncCollection collection, Boolean createSubscription, Boolean tryNullSync)
   at Microsoft.Exchange.AirSync.SyncCommand.OnExecute()
   at Microsoft.Exchange.AirSync.SyncCommand.ExecuteCommand()
   at Microsoft.Exchange.AirSync.Command.WorkerThread()
Inner exception follows...
Exception type: Microsoft.Exchange.Data.Storage.ObjectExistedException
Exception message: Could not create folder 12.
Exception level: 1
Exception stack trace:    at Microsoft.Exchange.Data.Storage.FolderCreatePropertyBag.CreateMapiFolder()
   at Microsoft.Exchange.Data.Storage.FolderCreatePropertyBag.SaveFolderPropertyBag(Boolean needVersionCheck)
   at Microsoft.Exchange.Data.Storage.CoreFolder.Save(SaveMode saveMode)
   at Microsoft.Exchange.Data.Storage.Folder.Save(SaveMode saveMode)
   at Microsoft.Exchange.Data.Storage.SyncState.CreateSyncStateFolderInFolder(SyncStateInfo syncStateInfo, Folder syncStateParentFolder, PropertyDefinition[] properties, Object[] values, ISyncLogger syncLogger)
Inner exception follows...
Exception type: Microsoft.Mapi.MapiExceptionCollision
Exception message: MapiExceptionCollision: Unable to create folder. (hr=0x80040604, ec=-2147219964)
Diagnostic context:
    Lid: 55847   EMSMDBPOOL.EcPoolSessionDoRpc called [length=118]
    Lid: 43559   EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0][length=220][latency=0]
    Lid: 52176   ClientVersion: 15.0.1156.10
    Lid: 50032   ServerVersion: 15.0.1156.6010
    Lid: 23226   --- ROP Parse Start ---
    Lid: 27962   ROP: ropCreateFolder [28]
    Lid: 17082   ROP Error: 0x80040604
    Lid: 25953  
    Lid: 21921   StoreEc: 0x80040604
    Lid: 27962   ROP: ropExtendedError [250]
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 41352   qdwParam: 0x8D5B06669E9BE0C
    Lid: 55033   dwParam: 0x0
    Lid: 10786   dwParam: 0x0        Msg: 15.00.1156.000:INTEXCH
    Lid: 1750    ---- Remote Context End ----
    Lid: 31418   --- ROP Parse Done ---
    Lid: 22417  
    Lid: 30609   StoreEc: 0x80040604
    Lid: 29073  
    Lid: 20369   StoreEc: 0x80040604
    Lid: 63664  
    Lid: 40448   StoreEc: 0x80040604
Exception level: 2
Exception stack trace:    at Microsoft.Mapi.MapiExceptionHelper.InternalThrowIfErrorOrWarning(String message, Int32 hresult, Boolean allowWarnings, Int32 ec, DiagnosticContext diagCtx, Exception innerException)
   at Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, IExInterface iUnknown, Exception innerException)
   at Microsoft.Mapi.MapiFolder.InternalCreateFolder(String folderName, String folderComment, Boolean openIfExists, Boolean createSearchFolder, Boolean instantSearch, Boolean optimizedConversationSearch, Boolean createPublicFolderDumpster, Byte[] folderId, Boolean createInternalAccess)
   at Microsoft.Exchange.Data.Storage.FolderCreatePropertyBag.CreateMapiFolder()
--- Exception end ---
serialbandCommented:
My guess is that there was corruption in creating a folder because a folder existed and was locked from a previous failed sync completion.  Removing the account cleared that profile and adding it back created a new profile that did not include the corrupt folder or a folder that was held in use.
RDCitAuthor Commented:
Fixed it by removing the account. hard rebooting the phone and readding the account.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.