BackupAssist error "The backup of volume (EFI System Partition) (100.00 MB) could not be completed"

Hyper-V server with two Windows 2016 VMs.
BackupAssist on the Hyper-V manager and attempting to perform a System Protection backup to a LAN connected NAS drive.
The Hyper-V Manager is in a Workgroup. The two VMs are in a domain - VM#1 is the PDC01 and VM#2 is DB01 (SQL Server).
When I run the backup for PDC01 I get error "The backup of volume (EFI System Partition) (100.00 MB) could not be completed."
ClintonKAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Most in-guest backup software products will only back up the NTFS partitions. ShadowProtect is like that and that's our go-to in-guest backup product.
0
Davis McCarnOwnerCommented:
What version of Backup Assist and what error is listed in it's logs?
0
ClintonKAuthor Commented:
BA Version 10.3.1
The Progress Log shows this. Just before as it fails it says it can't find the EFI partition.

Retrieving volume information...
This will back up (EFI System Partition),(C:),RAID1(D:),RAID10(E:), HyperV\PDC01, HyperV\DB01, HyperV\Host Component to \\jglnas001\JANDG.
The backup operation to \\jglnas001\JANDG is starting.
Summary of the backup operation:
------------------
The backup operation stopped before completing.
The backup operation stopped before completing.
Detailed error: The specified backup disk cannot be found.
Log of files successfully backed up:
C:\Windows\Logs\WindowsServerBackup\Backup-04-05-2018_17-26-28.log

Log of files for which backup failed:
C:\Windows\Logs\WindowsServerBackup\Backup_Error-04-05-2018_17-26-28.log

There was a failure in preparing the backup image of one of the volumes in the backup set.
The specified backup disk cannot be found.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Davis McCarnOwnerCommented:
From this:
https://community.spiceworks.com/topic/416480-windows-server-2008-r2-backup-failed

"Because the EFI is FAT32 formatted, it cannot be backed up using the Volume Shadow Service that is used for backups.  It has to be handled manually. Luckily, it does not contain changing data, so just take a manual copy once and don't use the backup software to try to back it up, there is no need for it to be in your regular backup set."
0
ClintonKAuthor Commented:
I've created a new Test VM which is just a standard Window 2016 build and then tried to backup just that VM only.
The Hyper-V manager is in a workgroup and the VMs are in a domain. The backup user is a local Hyper-V user.
I keep getting failures of the type "The backup of volume RAID1(D:) could not be completed. Error: The mounted backup volume is inaccessible. Please retry the operation."
I don't suppose it could be a permissions thing could it? I can't believe BackupAssist can't backup a standard VM
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
It sounds like its saying that the _destination_ volume is the problem not the source.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ClintonKAuthor Commented:
Yes, I didn't think of that. I'll check the NAS
0
noxchoGlobal Support CoordinatorCommented:
BackupAssist is nothing than a shell for Windows Server Backup which actually does the  job in background.
Have you tried to backup the same volume to the second virtual drive in this machine? This would at least give you a hint if the problem is in backup destination or in that 100MB EFI partition.
0
ClintonKAuthor Commented:
The problem was in fact to do with the destination rather than the source (very misleading messages IMHO).
I reconfigured the backup to use a data container (vhxd file) and all backs up OK.
(I have some issues with the restore but I'll save those for another post.)
Thanks all for your input.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.