TX packets error & Collisions

Hi,

I am seeing a lot of collisions and errors on a WAN port (Sophos SG210) which connects to fiber NTU ( Cisco ME 3400E)

This is 100Mb up/down fiber but I am getting around 60Mb download and 3Mb upload. I think the cause of the slow upload speed is because of the packet collisions and errors.

I get around 70Mb/70Mb when I connect my laptop directly to the NTP.

What would be the cause of the problem?

Here is ifconfig on the WAN link on SG210.

eth1   Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
          inet addr:110.xxx.xxx.xxx Bcast:110.xxx.xxx.xxx Mask:255.255.255.252
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:373271 errors:0 dropped:0 overruns:0 frame:0
          TX packets:220080 errors:2306 dropped:0 overruns:0 carrier:2306
          collisions:128842 txqueuelen:1000
          RX bytes:527821557 (503.3 Mb) TX bytes:48346583 (46.1 Mb)

 ethtool eth1
Settings for eth1:
        Supported ports: [ TP ]
        Supported link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Advertised link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: off (auto)
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                              drv probe link
        Link detected: yes
Patrick KimAsked:
Who is Participating?
 
JustInCaseConnect With a Mentor Commented:
Little background on duplex negotiation process.
If one side is manually configured for full or half duplex - other side will always fall back to half duplex operation. So, both sides MUST be configured for auto negotiation or manually configured with specific setting (half or full duplex) to avoid errors (Also, if interfaces are functioning as half duplex mode there will always be some error types under interfaces).
However, in some cases speed also need to be hard coded (for example older Cisco devices will not even allow to configure duplex without hard coding speed first). If link is going down when duplex is manually configured and not coming up, most likely for whatever the reason, interface speed negotiation failed. So, try to hard code speed on both interfaces to the same value.
Try whatever option you can configure and check if interfaces are working correctly. If you are unlucky, some bug can prevent link from functioning properly whatever you configure, but let's hope that some setting will support  100 speed with full duplex operation.
0
 
JustInCaseCommented:
Your problem is:
Advertised auto-negotiation: Yes

Speed: 100Mb/s
Duplex: Half
Potential causes:
- other side is configured manually with duplex full (while this side is trying to negotiate duplex)
- duplex negotiation failure (both cards are trying to negotiate duplex, but negotiation is unsuccessful)

When duplex negotiation fails network card will configure itself as half duplex.

WHat should be done:
- if duplex autonegotiation failed - configure both sides with duplex full
- if duplex is manually configured on neighboring device - this side also need to be configured with duplex full

Also, errors are consistent with the half duplex
carrier:2306

collisions:128842
1
 
Patrick KimAuthor Commented:
Thanks Justin,

I tried to manually set the duplex full on Sophos WAN port but the link goes down as soon as I changed to full duplex. Does that mean the Cisco port needs to be configured full duplex manually?
0
Firewall Management 201 with Professor Wool

In this whiteboard video, Professor Wool highlights the challenges, benefits and trade-offs of utilizing zero-touch automation for security policy change management. Watch and Learn!

 
nociSoftware EngineerCommented:
Yes appearantly the auto negotiation fails...
so put bot on full duplex.
0
 
Patrick KimAuthor Commented:
Thanks. I have just changed the WAN port to full duplex and I am not getting any collisions nor errors but the speed is still 100Mb. If I change this to 1000Mb, the link goes down.

Would 100Mb speed on the WAM port mean that it allows 100Mb up and down at the same time?
0
 
JustInCaseConnect With a Mentor Commented:
Yes. When link is full duplex it is 100Mb in each direction.

You're welcome.
0
 
Mlenis11Commented:
Check to make sure the other side speed on the port is set to 1000 before you change your side to 1000.
0
 
Patrick KimAuthor Commented:
The other side was configured full duplex and speed set to 100. I changed WAN port full duplex and set 100 speed then all working fine.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.