Error 6118 for Net View

I have four peer to peer computers using Windows 10.   "net view"  only returns a 6118 error for all computers.  I can ping each computer by IP address.  

I have tried everything. Nothing works.   So each computer cannot fully communicate with each other except using HomeGroup which is limiting.   "The list of servers for this workgroup is not currently available."

thank you
bodywiseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
Why would you need net view, what for? You can map Shares without.
0
N8iveITCommented:
Can you ping by name? I'm assuming the answer is no.
0
bodywiseAuthor Commented:
The basic problem is Network connections.  I cannot fully connect to each of these computers.  I can ping the IP address and by name.  This used to be a master browser problem.  It seems master browser is no longer referenced.  

Net view should show all computers.  It does not.  Thus the 6118 error.  Of all the answers online none correct this problem.  And it is a problem on every computer on this network.   These are all CAT6 ethernet.

The goal is networking all computers.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

McKnifeCommented:
"I cannot fully connect to each of these computers" - please be more specific about that detail.
If you have a share "ShareA" on machine A and a user UserA on that machine, will, when executed on machine B, this command work:

net use x: \\machineA\shareA /user:usera passwordofUserA

Open in new window

?
0
bodywiseAuthor Commented:
I started this thread asking why "net view" hangs and then gives error message 6118.   That would allow me to see all computers networked on the LAN in peer-to-peer configuration.  

When I click on "file explorer" I should see each computer under "network."   I don't  see all computers although I can ping each one by name and IP address.  

So it is a GUI interface not command line connection I am seeking.   The net view command is simply validating or not validating that all computers are visible.
0
McKnifeCommented:
Net view will not return results under a lot of circumstances. If you turn off network discovery (off by default) AND netbios over TCP/IP is off as well (that is a setting that by default is decided by your router, not by windows), then net view would not return any sharenames and network neighborhood would be totally empty, although nothing is wrong. However, you would not see any error message like you do - quite likely, there is either some component defective or simply some 3rd party firewall(s) is/are active.

So please take the analytical approach, look at the state of netbios over TCP/IP, look at network discovery. And then share the output of the command I gave you.
0
N8iveITCommented:
Just to see if your security settings are correct, can you go to Start, Run (or Windows Key+R) and type \\<ip address> or \\<ip address>\<sharename> ?

This should show something and should let you know if the shares are viewable.
0
bodywiseAuthor Commented:
Sorry for delays.   Original question was never answered.  Why the error 6118.  Why Net View shows nothing.

Then that leads to why computers are LAN connected but not talking laking to each other.

Your suggestion \\<ip address>\<sharename> returns: The network name cannot be found.

but if I ping <computername> it shows the correct local IP address
ping <local IP> shows reply from IP address.

Each computer shows different connections.  The <home group> is not the same as the <network group>.  

thank you
0
McKnifeCommented:
If you Need help with the suggestions, just say. So far, You did not give Feedback on mine.
0
bodywiseAuthor Commented:
Thank you for responding and persisting. These suggestions are quite generic.  TCP/IP and NetBIOS have all been enabled . That is not the problem.

You say there are various reasons for error 6118.  What are the reasons?   And I still have no answer to why this line appears:
The list of servers for this workgroup is not currently available.    this appears to be an indexing or master browser problem.

I do not fully understand your command line because it involve "share"   The "net view" should bypass any shares.  It should simply reveal computers that are connected. That is why a ping of the IP address or computer names is successful. The computers are linked.  

It can't be a defective component or device because the command "net view" fails on all four computers.  It is not a firewall problem.  

Again, I do not have this problem any of my computers at work. Although there have been spurious network sharing problems at work in a similar vein.

thank you
0
bodywiseAuthor Commented:
Thank you for connecting. You're right. This is a very long thread. It is old. It involves old conventions.

But it does exactly pinpoint the problems I'm having. Exactly. Unfortunately, the person who submitted the question said "I solved it." Without showing how he solved the problem. There's so many tweaks. Almost always these network problems are simple and not complex.

The network is not working. Despite all of the usual switches. Thank you again for your comments. I am at a loss. The LAN network does not work now.  Although I have never been able to see the results with LM hosts or hosts files, it is possible that is the answer.   Somewhere, a lookup table is not being constructed properly.
0
McKnifeCommented:
The suggestions are not generic but are normal troubleshooting steps that need to be checked before further assumptions are made.
"TCP/IP and NetBIOS have all been enabled . That is not the problem ...It is not a firewall problem"
You don't know that. If I use "net view" here in my domain network, the output I get is "There are no entries in the list" - although anything here works as needed and I can ping any machine. Ping has nothing to do with share access and should not be mixed with net view or confused with what net view is for.

I would get entries and output from net view if I enabled "netbios over tcp/ip" which you haven't confirmed (you confirmed to have "netbios enabled" and "tcp enabled". You did not yet confirm that you enabled network discovery - do that now, please.

I am not jumping to conclusions, else I would assume that there is a connectivity problem due to 3rd party firewalls, because net view would not return an error under normal circumstances.
0
bodywiseAuthor Commented:
Thank you again.   All that has been done.  That is why I considered this generic.  It is what everyone suggests.   It has all been done.  

What you see is not what I see.   And you used the keyword -- Domain.   This is a peer-to-peer workgroup.  Not a domain controller.   Not using windows server.  

Here is Ipconfig:  

Windows IP Configuration

   Host Name . . . . . . . . . . . . :  MyComputer
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : BC-AE-C5-xx-xx-xx
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::9ca1:6c53:602c:9afc%6(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.96(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Monday, May 14, 2018 9:18:22 AM
   Lease Expires . . . . . . . . . . : Tuesday, May 15, 2018 9:19:10 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 62697157
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-21-F4-BB-08-BC-xx-xx-xx-xx-xx
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 1:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:9d38:90d7:802:3338:b6a3:b19a(Preferred)
   Link-local IPv6 Address . . . . . : fe80::802:3338:b6a3:b19a%3(Preferred)
   Default Gateway . . . . . . . . . : ::
   DHCPv6 IAID . . . . . . . . . . . : 117440512
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-21-F4-BB-08-BC-xx-xx-xx-xx-xx
   NetBIOS over Tcpip. . . . . . . . : Disabled

And nbtstat -a mycomputer

Ethernet:
Node IpAddress: [192.168.1.96] Scope Id: []

    Host not found.

SecureLine:
Node IpAddress: [0.0.0.0] Scope Id: []

    Host not found.

>net view
System error 6118 has occurred.

The list of servers for this workgroup is not currently available

Firewall disabled.  All virus checkers off.
0
McKnifeCommented:
What has not been done yet is simply follow the suggestion to try map a network drive thuis way:
net use x: \\machineA\shareA /user:usera passwordofUserA
and share the output. You wrote
"I do not fully understand your command line because it involve "share"
Let me ask you: you would need the network to share files, right? The net view command is usually not used without parameters like you did (which will only list computers that are seen), but you would use it to display share as in
net view \\machineA

Or what would you like to do with the networked machines?
If it's also about shares, please share the output of said command to make progress.
0
bodywiseAuthor Commented:
I never solved the initial problem. Net View.  Error 6118.   But the underlying problem was computers not showing up on "network" using windows explorer.   LAN was not useable although they were all connected.

I have found almost all networking problems are simple  It's a matter of one switch.  The challenge?  Which switch?

When asking about file and printer sharing is it public, private or all?    

The solution was network settings --> reset network.    That solved the invisibility of computers.  

Now they all show up and are accessible .   Why?  I have no idea.   But it works.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
Good!
To close, please select your own comment as answer.
1
bodywiseAuthor Commented:
Initial question never answered or solved.  But it was only a path to discovering why the LAN was not showing all connected computers.   Network Reset was the best and easiest answer.    The common exhortation to file and printer discovery needs to be more specific.   Private, public or all.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.