The Active Directory DOmain Controller (AD DC) for the domain "xxxxx.local" could not be contacted

I had to send a laptop to be repaired & they replaced the mainboard.  When I got it back I thought I'd installed Windows updates before re-connecting it to the domain, because there's a Features Update available that won't install while its on the network.  So I ran the update & now the laptop can't reconnect to the domain, I'm getting the error "The Active Directory DOmain Controller (AD DC) for the domain "xxxxx.local" could not be contacted".

I found the thread https://www.experts-exchange.com/questions/28996502/THe-Active-Directory-DOmain-Controller-AD-DC-for-the-domain-che-local-could-not-be-contacted.html, which exactly describes my problem, unfortunately it ends with the laptop being replaced.  I've tried editing the "host" file, I've tried all the ipconfig commands, I've installed an update to the 1803 Feature update, I've hardcoded the DNS server addresses into the network settings, but still I get the error.  Frustratingly I can see the server in the network, I can even connect to it if I put in the admin login & password, I can ping it, I can ping the router, I just can't join the domain.  

When I restart the laptop, I always get this same set of Event Log errors from DistributedCOM, event ID 10016, is this possibly connected to the connection issues?
 
"The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{D63B10C5-BB46-4990-A94F-E40B9D520160}
 and APPID
{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
 to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool."


I have no idea if the problem is related to the mainboard being replaced, or the 1803 update.  Any ideas?
matavaiIT ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jose Gabriel Ortega CastroCEO Faru Bonon IT - EE Solution ExpertCommented:
does it have the same "hostname" as the previous before sending it to repair?
if so, you need to remove the computer object 1st and then try to re-join it to the domain.
matavaiIT ManagerAuthor Commented:
The 'hostname' in the ipconfig listing is still the computer name as i assume it was before, I must admit I've never looked at that field before.  
 
How do you remove the computer "object"?
Jose Gabriel Ortega CastroCEO Faru Bonon IT - EE Solution ExpertCommented:
well open cmd and run  hostname
that would be the name of the computer.

-----

To remove the object from the Ad you need to go to the AD Users and Computers, go to the root of your domain / expand it / go to Computers OU / find the one with the same name (hostname), Right click, delete.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

matavaiIT ManagerAuthor Commented:
Gave that a try, no joy.  The computer name is still listed in DHCP, under both its wireless & wired connections, remove them there as well maybe?  I've done this process before with laptops & PCs heaps of times, but this is probably the first time after a mainboard has been replaced, or after installing update 1803.
Jose Gabriel Ortega CastroCEO Faru Bonon IT - EE Solution ExpertCommented:
Well remove it it's safe to remove it if you aren't using it .
but I don't think that would be the issue.
What's the issue when you removed the computer from AD, and re-added it again? same error?
matavaiIT ManagerAuthor Commented:
Solved it, but don't understand why.  Instead of typing the domain in as I always have as XXXXX, I typed it in as XXXXX.local & bingo, instant connection.  Does that imply something has changed on the server?
Jose Gabriel Ortega CastroCEO Faru Bonon IT - EE Solution ExpertCommented:
Probably is resolving with the FQDN ( full name)
instead of the short Pre-windows 2000 domain

FQDN: server.<domain>
Domain ex: domain.com
pre windows 2000 format: domain

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
matavaiIT ManagerAuthor Commented:
Turned out to be user error in that I hadn't tried everything I should have, but points to Jose for pointing me in the right direction.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.