I'm having difficulty establishing an SSH connection to the Linux system running in a virtual machine on my Windows laptop

I have a Dell laptop (running Windows 10) where I'm hosting OpenSuSE Linux (Leap 42.3) in a virtual machine. Although I can ping the virtual machine, I haven't been able to connect to it using the SSH protocol. As far as I can tell, the secure shell demon is running on the Linux system. I've tried a couple of SSH Windows clients – specifically, SecureCRT and SecureFX. Additionally, I've tried running the SSH client from the Windows command prompt. I haven't seen any error messages. Instead, the connection simply times out.

Networking is not my forte, but I'm familiar with SSH. I've configured it on UNIX systems many times, but that was years ago. These days I'm doing so only on rare occasions. Consequently, there's usually some small detail that I overlook. Any assistance would be greatly appreciated!
babyb00merAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

serialbandCommented:
First, see if you can ssh from the Linux system to itself.  If that works, then you may have an issue with the firewall.  If that doesn't work, then you may have  issues with sshd.  Run ssh with the verbose options.

ssh -vvv
0
babyb00merAuthor Commented:
Is my face red! :-|

It turned out to be the server configuration. The server daemon (sshd) was configured to reject password authentication (PasswordAuthentication no). I edited /etc/ssh/sshd_config and changed the value of that variable from no to yes. Then I restarted the daemon:
rcsshd restart

Open in new window

.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
babyb00merAuthor Commented:
UPDATE!

The next day I noticed that, once again I couldn't access the virtual machine using the SSH protocol!? I discovered that the SSH server daemon had not been started when the system booted. To rectify that, I ran the following command:
systemctl ssh enable

Open in new window

0
babyb00merAuthor Commented:
thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.