11G to 9i import table not working

I tried to export 11G table and want to import that table but getting error.
On 11G database I have used below command:
exp SCHEMA1/password@DB1File=HISTORYDATA.dmp log=HISTORYDATA.log tables=(HISTORYDATA)

AND Tried to import that on 9i database using below command but getting error.
imp SCHEMA2/Password@DB2File=HISTORYDATA.dmp FromUser=Schema1 ToUser=Schema2 tables=(HISTORYDATA)
and error is Not a vaild export file, header failed verification

 Please help me to give solution.
SudhanshumAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slightwv (䄆 Netminder) Commented:
If it will connect, which I doubt, I believe you have to use the 9i export against the 11g database.

If that fails, you can try going through an intermediate 10g database or use spool to generate CSV and SQL*Loader.
0
SudhanshumAuthor Commented:
what is 9i export against the 11g database.?
0
slightwv (䄆 Netminder) Commented:
Yes, going from memory but I remember you have to use the lower version of export.  9i has no way of knowing what the 11g export file looks like.

I really doubt the 9i export will connect to an 11g database but you can try.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Geert GOracle dbaCommented:
you might be able to setup a database link to the 9i

or you'll have a lot of work:
https://docs.oracle.com/database/121/SUTIL/GUID-F8DEC519-5868-42C3-AD7A-7FA28F82983A.htm#SUTIL2857
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
slightwv is correct - you always have to export with the lowest exp version of source and target, and import with the target one. More recent imp's can read older formats, but not vice versa.

Otherwise, you can use SQL*Developer to create a CSV file or INSERT statements, as you only want to export content of a single table.
0
Mark GeerlingsDatabase AdministratorCommented:
"what is 9i export against the 11g database?"
That is using your Oracle9i software to connect to the Oracle11g database and running the export from your Oracle9i executables.  If these two databases are on the same network, that will work if you add an entry in the tnsnames.ora file on the Oracle9i server for the Oracle11 database.

If these two Oracle databases though are on separate networks and you cannot ping one from the other, then you have to use one of the options that others have already mentioned here.

Oracle has never supported taking an export from a higher database version and importing that into a lower database version.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Databases

From novice to tech pro — start learning today.