USB flash drive cannot be assigned drive letter or formatted

I get the same error on several different windows machines.  When I stick the same, not other, SB stick in and attempt to assign a drive letter.  I also get this error if I try to format the thumbdrive.

The drive can be formatted by Paragon software and even assigned a drive letter.  Even after applying the changes disk management cannot assign a drive letter (gets same error), or format the drive again.  The drive appears in the device manager.  The drive also appears on my linux (kali) box.

Windows 10 Pro - latest build
USB 2 4gb diskGO by EDGE

Disk manager running as Administrator encounters error
LVL 32
Thomas Zucker-ScharffSolution GuideAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

N8iveITCommented:
Others like it acting the same way or the only one of its kind?

Being that it is only 4 GB, if there is no reason to keep it, I would write it off as bad or defective and buy another.
Thomas Zucker-ScharffSolution GuideAuthor Commented:
So far no others are acting like it.  It is small, but it was working before I formatted it.  SFC /scannow didn't find any errors either.
N8iveITCommented:
NOTE: THIS CAN BE DESTRUCTIVE IF YOU ACCIDENTALLY DELETE THE WRONG DEVICE(S). Not responsible for accidents, tax, title and tags extra. Batteries not included ...

However, it might be something conflicting in a hidden device. I would enable hidden devices (see http://www.thewindowsclub.com/show-non-present-devices-windows ), check device manager to see if there are any old affiliated devices showing up which could be conflicting with this device, delete them, reboot and try the device again.

Again, if no luck, I would purchase another.

I actually had this fix a RAID / bootup issue on a server ... was sweating bullets when I tried it ... but it worked!
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Wayne88Commented:
I have used Phison Format & Restore to do a low level reformat to the USB flash drives.  This should fix the problem.

Beware: a search in Google returned a few links of this tool but they are suspicious.  Always scan for virus before running any downloaded software.

Failing this, you can try using others such as https://www.techspot.com/downloads/5265-low-level-format-tool.html but I have never used this one so I can't comment on it.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
N8iveITCommented:
My approach is "Method 5" is this lengthy list of things to try in Windows 10; https://appuals.com/fix-usb-device-not-recognized-on-windows-10/

Didn't realize there were so many things to try!
nobusCommented:
check what happens on another PC with this stick -  can you format it?
Thomas Zucker-ScharffSolution GuideAuthor Commented:
@nobus

other pc gives same error
nobusCommented:
then the problem is with the stick
does it have any software on it?  encryption or so ?
more info here :  http://us.edgememory.com/index.php/usb-flash-drives/item/30-diskgo-secure-pro-usb-flash-drive
Thomas Zucker-ScharffSolution GuideAuthor Commented:
I did a low level format on it using Hard Disk Low Level Format Tool and it is good to go.

Thanks All.
Wayne88Commented:
I am glad I was able to help and thanks for getting back.  Cheers!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
USB

From novice to tech pro — start learning today.