Windows 10 not opening document types when browsing shared directory using "File://" protocol

I'm hoping that someone on here can please explain what might be preventing this from working.

We've moved to Windows 10 Pro x64. On our Intranet we have an iFrame with the 'src' set to "file://SERVER-NAME/SHARED-FOLDER". This allows us to browse the directory and open files saved there. Document types saved in the directory are subfolders, Excel (.xlsx), PDF (.pdf), and Word (.docx).

This directory is shared in a central location and the user 'Everyone' has Read Only access to it. It works fine on Windows 7 Pro x64.

We can now no longer open PDF or Excel documents from this page. Word documents open fine, and we can still traverse through directories. Behaviour differs between browsers:

In Microsoft Edge, instead of being embedded in the iframe the directory gets opened in Windows Explorer, allows traversal, and all files open normally (since it's just opening from Explorer). I have only tested this browser on Windows 10.

In Google Chrome nothing happens on either Windows 7 or 10. I have researched into this and it's intentional (source https://community.spiceworks.com/topic/533009-opening-file-links-from-within-chrome).

In Internet Explorer 11 (latest version) on both Windows 7 & 10 you can traverse the directories. Files such as .docx open fine in Microsoft Word.
When I try to open a file in Microsoft Excel, the program Excel opens but it's blank and doesn't load the document. Subsequent attempts to open simply create new Excel instances.
Attempting to open PDF files does nothing. Occasionally the mouse cursor will display a loading wheel for a couple of seconds but nothing more. Right-clicking on the PDF and choosing to Open with Word does open correctly, converting the PDF document within Word as is usual.

I suspect that there is something about Windows 10 which is 'more secure' and has caused this behavioural change. Has anyone else come across this, and if so what did you do to resolve it?
I have already poked at a number of settings (such as ensuring Protected Mode is disabled in Internet Explorer) to no avail.

Thanks,
David
dgloverukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dgloverukAuthor Commented:
To follow on from this, I have now found the solution.

We have Protected Mode enabled for our Local Intranet zone. This does not seem to affect Internet Explorer 11 on Windows 7, but does on Windows 10. Disabling this (through Group Policy in my case, using the instructions at this link https://arstechnica.com/civis/viewtopic.php?t=1250955) resolved the issue and allows documents to be opened again, albeit with a security warning of 'Do you trust this file?'
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dgloverukAuthor Commented:
See solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.