need help whit nat translation

Cisco 800

need help whit nat translation


i set u the nat to Dialer0 but the wan wont let me get a ping to 8.8.8.8

--------------------------------------------show run
hostname G1_router
!
ip source-route

!
ip dhcp pool ccp-pool
 dns-server 10.10.10.1
!

interface Vlan1
 ip address 10.10.10.200 255.255.255.0
!
interface Dialer0
 description *** WAN ***
 mtu 1492
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname *****@EDPNETFIX
 ppp chap password 0 ******
 ppp ipcp dns request
!
ip route 0.0.0.0 255.0.0.0 Dialer0
!
LVL 1
Nadir Van ThielenAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Benjamin Van DitmarsSr Network EngineerCommented:
int vlan 1
ip nat inside
!
int dialer 0
ip nat outside
!
ip nat inside source list 100 interface dialer0 overload
!
accesslist 100 permit ip 10.10.10.0 0.0.0.255 any
!
no ip route 0.0.0.0 255.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!

goodluck with testing.
1
Nadir Van ThielenAuthor Commented:
i test-it it out , an came to the flowing result.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of x.x.x.x
.....
Success rate is 0 percent (0/5)

command # debug ppp negotiation    
but the is no hand sake

only when i unplug the wall socket
 %CONTROLLER-5-UPDOWN: Controller VDSL 0, changed state to down


is it something to do that the nat table don't rout to the dialer
0
Benjamin Van DitmarsSr Network EngineerCommented:
do
show users
show controllers vdsl 0
show int dialer 0

debug pppoe events

and see why youre controller doesn't want to come up
0
Become a Leader in Data Analytics

Gain the power to turn raw data into better business decisions and outcomes in your industry. Transform your career future by earning your MS in Data Analytics. WGU’s MSDA program curriculum features IT certifications from Oracle and SAS.  

Benjamin Van DitmarsSr Network EngineerCommented:
please send me a full config
0
Nadir Van ThielenAuthor Commented:
G1_router#sh run
Building configuration...

Current configuration : 2225 bytes
!
! Last configuration change at 09:27:56 GMT Wed Feb 6 2036 by nvthielen
! NVRAM config last updated at 08:47:59 GMT Wed Feb 6 2036 by nvthielen
! NVRAM config last updated at 08:47:59 GMT Wed Feb 6 2036 by nvthielen
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname G1_router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
memory-size iomem 10
clock timezone GMT 1 0
crypto pki token default removal timeout 0
!
!        
ip source-route
!        
ip dhcp pool ccp-pool
 dns-server 10.10.10.1
!
!
ip cef
ip domain name pi-rom.com
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid C887VAMG+7-K9 sn FCZ1620C007
!
!
object-group network local_lan_subnets
 10.10.10.0 255.255.255.128
!
vtp mode transparent
username nvthielen privilege 15 secret 4 zjq.B5VxCUUN8KOXuT3U2A9sRr21TH7EbPYH9x.y7hU
!
!
controller VDSL 0
!
controller Cellular 0
!
vlan 2
 name Rede_Fixa
!
vlan 3
 name Rede_Wireless_WPA_Loja
!
vlan 4
 name Rede_Wireless_WPA_ED
!
vlan 5
 name Rede_Voz
!
!
track 1 ip sla 1 reachability
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface Cellular0
 no ip address
 encapsulation slip
!
interface Vlan1
 ip address 10.10.10.200 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Dialer0
 description *** WAN ***
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname xxxxxx.xxx@EDPNETFIX
 ppp chap password 0 XXXXX
 ppp ipcp dns request
!
ip local policy route-map track-primary-if
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
!        
!
control-plane
!
banner login ^C this device is protectet by ACM ^C
!
line con 0
line aux 0
line 3
 no exec
line vty 0 4
 access-class 1 in
 exec-timeout 15 0
 login local
 transport preferred ssh
 transport input telnet ssh
!
end
0
Benjamin Van DitmarsSr Network EngineerCommented:
this makes sense now. you dont have youre vdsl interface connected to the dialer.

what is the vlan youre provider is using for the vdsl ?

do

conf t
int ethernet 0
no shut
!
int ethernet0.x {x is youre provider vlan}
  encapsulation dot1q x {x is youre provider vlan}
  pppoe enable group global
  pppoe-client dial-pool-number 1
  no shut
!

this wil fix youre config
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Benjamin Van DitmarsSr Network EngineerCommented:
and i miss the nat config and default route

ip nat inside source list 100 interface dialer 0 overload
ip route 0.0.0.0 0.0.0.0 dialer0
!
access-list 100 permit ip 10.10.10.0 0.0.0.255 any
!

then you need to fix youre dhcp pool

ip dhcp pool ccp-pool
 network 10.10.10.0
 default-router 10.10.10.200
 dns-server 10.10.10.1
 lease 0 8
!
0
Nadir Van ThielenAuthor Commented:
don't know but i think it will by something like that
i wile answer that question when i get a mail back from the provider .
0
Nadir Van ThielenAuthor Commented:
go the mail back from the provider and need to by set en on VLAN

tnx for the help
0
Benjamin Van DitmarsSr Network EngineerCommented:
youre welcome
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.