Office 2010 losing activation

Office Pro Plus 2010...
On Win 7 Office was installed and ran perfectly for about 3 years...
Upgraded PC to W7...installed same version of Office...activated and running perfect...

Now after about 3 months...Office is losing it's activation...
When I open any Office program...it gives me the Not Activated message and the activation wizard...
I put in the SAME code I used before...it validates...hit the Install now button and things progress normally...

But the look of things and the actions completed...Office is activated...

But if I open Word, for example...I get the same Product not acativated message...

How can I fix this...???
LVL 2
Steve MutchlerIT TechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

FOXActive Directory/Exchange EngineerCommented:
Did you try to run a repair on office?  
Control Panel>Program and features>highlight Microsoft office 2010....at the top select Change then click Repair
0
Steve MutchlerIT TechAuthor Commented:
Fox...did the repair...no joy...
Thinking uninstall with Revo...get registry cleaned and then that should give me a clean install...
0
FOXActive Directory/Exchange EngineerCommented:
Yes, let Revo clean it all out......great minds think alike  :)

or go to this site  Click 2010 and download the fixit tool to completely uninstall Office 2010
ref link:  https://support.office.com/en-us/article/uninstall-office-from-a-pc-9dd49b83-264a-477a-8fcc-2fdf5dbf61d8?ui=en-US&rs=en-US&ad=US#OfficeVersion=2010
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Steve MutchlerIT TechAuthor Commented:
I found this link...tried it...no joy...
https://kb.ucla.edu/articles/previously-activated-office-2010-constantly-loses-activation
So...if it's happening at UCLA...I'm guessing this is a bit of a problem...

Got the uninstall tool...I think I've used it before...
I'll uninstall with Revo first...then the tool should clean up anything left over...

I hope...
0
Steve MutchlerIT TechAuthor Commented:
Well...uninstalled Off 2010 using Revo...had 2 errors during uninstall...both saying that an uninstall was not working
and that I should restart Outlook and re-install...not sure what to make of that message...

BUT....Office DID uninstall...but Revo had NO registry edits to remove...strange....

After a reboot and a  reinstall everything seems to be working...

EXCEPT...It would NOT take my original activation code...but DID take the activation of another Office install...
I think this is...or at least it is my understanding....correct or not....that you cannot re-install Office 2010 immediatly after
an uninstall...you have to wait 30 days or something like that....which makes NO sense at all...

Anyway it's working...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.