Sonicwall WAN interface is a private ip

We have a Technicolor Modem/wireless router combo device given by Spectrum.  When Spectrum tech first set it up I could connect to is wirelessly and I could see the public wan IP as ie.  We plugged it into our Sonicwall device and everything is working fine.  Bridge mode is enabled and we have a dynamic public ip so I set it to DHCP.   I just want to know why  I'm getting a address of showing on my WAN.  I was expecting to see the public ip instead like

Wan interface
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Semper PhiSystems IntegratorCommented:
The Spectrum device appears to have a NAT.
jkimzlgAuthor Commented:
But Bridge mode is enabled so it should not be NATing
Semper PhiSystems IntegratorCommented:
Try disabling the DHCP scope for the LAN side.
"Bridge mode is enabled and we have a dynamic public ip so I set it to DHCP. "

Can we see the settings for the interface that's bridged to X1?
Blue Street TechLast KnightCommented:
Cable modems have cache. They take the last connected device's MAC and retain it.

Perform a network refresh with the SonicWALL attached. Then login to the SonicWALL and click Renew then Refresh. Everything should clear up.

If not then Bridge Mode is failing. Factory Reset the Modem. If that too fails, then request for a new Modem from your ISP.

I would also not use the Modem for anything except Ethernet translation - disable wireless, firewall, NAT, DHCP, etc. Bridge Mode should take care of many of the items but not all of them and each device will act differently. You basically do not want the modem to perform any (or as least as possible) security or NAT functions.

Let me know how it goes!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.