URLs to download drivers for intel rs2wc080 RAID controller card

What URLs can I use to download drivers for an Intel rs2wc080 RAID controller card for Server 2016?

I have already visited the https://downloadcenter.intel.com/product/43164/Intel-RAID-Controller-RS2WC080 website and have downloaded and installed several drivers.

However, this device appears with yellow exclamation points within Device Manager.

Where can I obtain the proper Server 2016 drivers for this device?

Intel SATA controller conflicts
IT GuyNetwork EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
There are two different Server 2016 drivers on this page below which is different than the page you used. Try the drivers here.

https://downloadcenter.intel.com/product/2092/Intel-RAID-Controllers
0
IT GuyNetwork EngineerAuthor Commented:
Doing what John said didn't fix the issue.

I moved the RAID card to a different PCI-E slot on the system board and now the RAID controller card no longer has the yellow exclamation points it used to have within Device Manager in Server 2016 DataCenter.within

However, the two SAS hard drives that are connected to this RAID controller card aren't recognized within Device Manager, Windows, or by any of the utilities that I downloaded and installed from this card's homepage.

What else can I do to get the SAS hard drives that are connected to this RAID controller card to be recognized?
0
JohnBusiness Consultant (Owner)Commented:
Have you contact the Server Manufacturer support people?  They would be able to help.  There are way more drivers for older machines, so maybe that card does not support Server 2016 very well.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

FOXActive Directory/Exchange EngineerCommented:
IT Guy-
In Device Manager right-click the Raid Controller, click properties>click Details tab>Click the "Property" dropdown and change it to Hardware ID.  Right-Click copy the top Hardware ID you see and paste in to google.  You may find the correct driver with a search of the Hardware ID
0
Shaun VermaakTechnical Specialist/DeveloperCommented:
Please give us an indication what type/version drivers you tried

Some other downloads can be found here
https://ark.intel.com/products/43164/Intel-RAID-Controller-RS2WC080
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
If the server has two processor sockets but only one populated make sure the RAID controller is plugged in to a PCIe slot controlled by the CPU. No CPU in the other socket will mean some PCIe slots are not connected.

As per the other Q, use the power supply female SATA connectors to power the SAS HDDs via the male connectors on the fan-out cable.
0
IT GuyNetwork EngineerAuthor Commented:
This server has two working CPUs.

It looked like I had gotten the right driver for this RAID controller installed but after a couple hours, the yellow exclamation point returned to the RAID controller card within Device Manager (and remains even after the server has been rebooted).

Here are the hardware IDs for this controller:

PCI\VEN_1000&DEV_0073&SUBSYS_92408086&REV_03
PCI\VEN_1000&DEV_0073&SUBSYS_92408086
PCI\VEN_1000&DEV_0073&CC_010400
PCI\VEN_1000&DEV_0073&CC_0104

RAID controller Hardware IDs
0
FOXActive Directory/Exchange EngineerCommented:
Go to the below link, filter by Operating System, (also click show more) to view all 3 driver options

ref link:  https://downloadcenter.intel.com/product/43164
0
JohnBusiness Consultant (Owner)Commented:
That is the same link as tried in the author's original post.
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
I suggest that the RAID controller is probably defective. Flash the firmware on the RAID controller to the newest version to see if that helps.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2016

From novice to tech pro — start learning today.