Attempting to use an NT account name with SQL Server Authentication

wasabi3689
wasabi3689 used Ask the Experts™
on
Logon Login failed for user . Reason: Attempting to use an NT account name with SQL Server Authentication.

I have a Windows domain account like gooled\solarexpert that is set as sysadmin on mssql database, connect to Solarwind application.  The application connection is not successful. I check the database log, it is "....Reason: Attempting to use an NT account name with SQL Server Authentication."

I use this account gooled\solarexpert  on other database with same setting, it's no issue to connect. Most are nnncet5ed successfully, only few of them is with this error message.

Any advice?

I have tried almost all suggestions posted from web about this error, it still doesn't work.

My server is mssql 2012
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Russell FoxDatabase Developer
Top Expert 2014

Commented:
This sounds like an issue with your connection string: can you post it (taking out sensitive information)?

Author

Commented:
where to get the connection string? from mssql or solarwind?
Top Expert 2016

Commented:
A Sql Server Account is not a windows account. the SA account should just be solarexpert
a SA account authenticates against the database itself and not via windows authentication
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
If I use sql server account to connect, no issues. If I use Winodws domain account, that error message popped up in sql server log.


gooled\solarexpert

gooled is domain or host, this is just makeup.
solarexpert is the account name.

Author

Commented:
We want to use Windows domain account to connect by Windows authentication, not allow sql server account by sql authentication
Nakul VachhrajaniTechnical Architect, Capgemini India

Commented:
If you want to use Windows Authentication, you do not need to supply a user name and password. Specifying "Integreated Security=true" or trusted connection in the connection string would tell the SQL Server that you intend to use Kerberos/Windows Authentication. It would automatically fetch the user context of the user who initiated the connection and authenticate.
Silly question, but are you certain that domain account has permissions to the solarwinds database? Typically when you set up SolarWinds you specify an account (either a SQL account or a domain account, but not both) and that's the one the polling engine (solarwinds server) uses to connect. Very few people give other accounts additional access to the db.

So I just want to verify that you are sure this account was given access at the outset.
Vitor MontalvãoIT Engineer
Distinguished Expert 2017

Commented:
The application connection is not successful
How are you setting the connection in the application?
I'm second Nakul in his suggestion to check if you connection string has the Integrated Security set to yes.
Vitor MontalvãoIT Engineer
Distinguished Expert 2017

Commented:
wasabi, a feedback will be appreciated.
Cheers.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial